Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-09-28 16:01:51 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-09-28 16:01:51 +0200
commitd9a1f22dbd055ff756fa324440994db58e4a9788 (patch)
treeba0880c5bc11c7e6a40cf2acc7afb666411dec2e /community
parent7348855ce72abfb3ff6320f1841ebcdcccc6b734 (diff)
community/clementine: another rebuild with a complete PKGBUILD
Diffstat (limited to 'community')
-rw-r--r--community/clementine/PKGBUILD46
1 files changed, 41 insertions, 5 deletions
diff --git a/community/clementine/PKGBUILD b/community/clementine/PKGBUILD
index 328858fa..49e4da25 100644
--- a/community/clementine/PKGBUILD
+++ b/community/clementine/PKGBUILD
@@ -1,8 +1,44 @@
-# rc2 disappeared, we have to rebuild because of protobuf
-sed -i '
- s/^pkgver=1.4.0rc2$/pkgver=1.4.0rc1/
-' PKGBUILD
-sha256sums[0]='96ba2f5f3ece47b2c1065e980dcc37ada93ea42cf37b794ee804514ce4a65459'
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: Stéphane Gaudreault <stephane@archlinux.org>
+# Contributor: BlackEagle <ike.devolder@gmail.com>
+# Contributor: Dany Martineau <dany.luc.martineau@gmail.com>
+
+pkgname=clementine
+pkgver=1.4.0rc1
+pkgrel=3
+pkgdesc='A modern music player and library organizer'
+url=https://www.clementine-player.org/
+license=(GPL)
+arch=(x86_64 i486 i686 pentium4)
+depends=(chromaprint gst-plugins-base-libs libcdio libgpod liblastfm-qt5 libmtp libmygpo-qt5
+ taglib protobuf qt5-x11extras projectm alsa-lib libpulse crypto++ hicolor-icon-theme)
+makedepends=(boost cmake qt5-tools sparsehash)
+optdepends=(
+ 'gst-plugins-base: "Base" plugin libraries'
+ 'gst-plugins-good: "Good" plugin libraries'
+ 'gst-plugins-bad: "Bad" plugin libraries'
+ 'gst-plugins-ugly: "Ugly" plugin libraries'
+ 'gst-libav: Libav plugin'
+ 'gvfs: Various devices support'
+)
+source=("https://github.com/clementine-player/Clementine/releases/download/${pkgver//+/-}/$pkgname-${pkgver//+/-}.tar.xz")
+sha256sums=('96ba2f5f3ece47b2c1065e980dcc37ada93ea42cf37b794ee804514ce4a65459')
+
+prepare() {
+ sed -e 's|CRYPTOPP cryptopp|CRYPTOPP libcryptopp|' -i $pkgname-${pkgver//+/-}/CMakeLists.txt # Fix crypto++ detection
+}
+
+build() {
+ cmake -B build -S $pkgname-${pkgver//+/-} \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DUSE_SYSTEM_PROJECTM=ON \
+ -DUSE_SYSTEM_TAGLIB=ON
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+}
# disable -Werror
eval "$(