Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-10-09 13:27:02 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-10-09 13:27:02 +0200
commitd163cb4066d3ddeb4f2daf857445915661766155 (patch)
tree0d806bca9060aa9974fddcf9a004ee3d679ac817 /community
parent088a1683d1b1c7e003aa749fc2ad293a017ad150 (diff)
community/rubygems: disabled rdoc for now, breaking cycle and conflict with ruby-rdoc
Diffstat (limited to 'community')
-rw-r--r--community/rubygems/PKGBUILD10
-rw-r--r--community/rubygems/rubygems-3.3.23-no-rdoc.patch14
2 files changed, 24 insertions, 0 deletions
diff --git a/community/rubygems/PKGBUILD b/community/rubygems/PKGBUILD
index 472071e2..e06368d4 100644
--- a/community/rubygems/PKGBUILD
+++ b/community/rubygems/PKGBUILD
@@ -15,3 +15,13 @@ eval "$(
)"
unset check
+
+source+=(rubygems-3.3.23-no-rdoc.patch)
+sha512sums+=(91a0c886b264f40ad80d3d6b0f494e6b4fa9b11b121943956b4484ea0763e6f959f6e87a6b844ecbd7b6b58752fe950297c489bf202cc78af4092707c6713bf0)
+eval "$(
+ declare -f prepare \
+ | sed '
+ $ i patch -p1 -i "$srcdir"/rubygems-3.3.23-no-rdoc.patch
+ '
+)"
+
diff --git a/community/rubygems/rubygems-3.3.23-no-rdoc.patch b/community/rubygems/rubygems-3.3.23-no-rdoc.patch
new file mode 100644
index 00000000..d4f78398
--- /dev/null
+++ b/community/rubygems/rubygems-3.3.23-no-rdoc.patch
@@ -0,0 +1,14 @@
+diff -rauN rubygems-3.3.23/lib/rubygems/commands/setup_command.rb rubygems-3.3.23-no-rdoc-patch/lib/rubygems/commands/setup_command.rb
+--- rubygems-3.3.23/lib/rubygems/commands/setup_command.rb 2022-10-05 16:34:09.000000000 +0200
++++ rubygems-3.3.23-no-rdoc-patch/lib/rubygems/commands/setup_command.rb 2022-10-09 11:13:47.750021079 +0200
+@@ -347,8 +347,8 @@
+ generate_ri = options[:document].include? "ri"
+ generate_rdoc = options[:document].include? "rdoc"
+
+- rdoc = Gem::RDoc.new fake_spec, generate_rdoc, generate_ri
+- rdoc.generate
++# rdoc = Gem::RDoc.new fake_spec, generate_rdoc, generate_ri
++# rdoc.generate
+
+ return true
+ elsif @verbose