Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-10-09 15:06:51 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-10-09 15:06:51 +0200
commita67764b7b25a10a662cef3e0bd5910b82b7c58e6 (patch)
tree664e1c12cdc6517f1c74f24cd061b051e6839a26 /community
parent5f870c53424219a2a7283d030c25e0e5842f66e3 (diff)
community/ruby-rake: rebuilding
Diffstat (limited to 'community')
-rw-r--r--community/ruby-rake/PKGBUILD22
1 files changed, 11 insertions, 11 deletions
diff --git a/community/ruby-rake/PKGBUILD b/community/ruby-rake/PKGBUILD
index a6209e1b..472071e2 100644
--- a/community/ruby-rake/PKGBUILD
+++ b/community/ruby-rake/PKGBUILD
@@ -1,16 +1,16 @@
-# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
-# and depend on 'ruby'
-makedepends+=(ruby-bootstrap)
-depends=()
-
-# install to final destination in /usr and not into /opt/ruby-xxx
+# bootstrapped packages in first step from /opt/ruby- contain
+# /opt/ruby-XXX/bin in the binaries in /usr/bin and they have
+# wrong architecture strings in native library code
+eval "$(
+ declare -f build | \
+ sed '
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
+ '
+)"
eval "$(
- declare -f package | \
+ declare -f package | \
sed '
- s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
- 3 i PATH="/opt/ruby-bootstrap-3.0.4/bin:${PATH}"
- /_gemdir/ a mkdir -p "${pkgdir}"/usr/bin/
- $ i sed -i "1s|.*|#\!/usr/bin/ruby|" "${pkgdir}"/usr/bin/rake
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"