Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2023-02-19 10:11:25 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2023-02-19 10:11:25 +0100
commit793166639e53b5a496d49ad4736a0b51ced5625e (patch)
tree6881909ac08200d4bcffde9a99a1a076f6fc85f1 /community
parent83310ead0f0fe42e7aeef85460027a3ce33d8003 (diff)
community/boost180-libs: readded ublas patch, flexible python version
Diffstat (limited to 'community')
-rw-r--r--community/boost180-libs/PKGBUILD27
1 files changed, 20 insertions, 7 deletions
diff --git a/community/boost180-libs/PKGBUILD b/community/boost180-libs/PKGBUILD
index 555a5a96..502a065e 100644
--- a/community/boost180-libs/PKGBUILD
+++ b/community/boost180-libs/PKGBUILD
@@ -1,10 +1,12 @@
-# Maintainer: iamawacko <iamawacko@protonmail.com>
-# Contributor: Evangelos Foutras <evangelos@foutrelis.com>
+options=(!lto)
+options=(!lto)
+options=(!lto)
+# Maintainer: Evangelos Foutras <evangelos@foutrelis.com>
# Contributor: Levente Polyak <anthraxx[at]archlinux[dot]org>
-# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
+# Contributor: Bart?omiej Piotrowski <bpiotrowski@archlinux.org>
# Contributor: Marius Knaust <marius.knaust@gmail.com>
# Contributor: Ionut Biru <ibiru@archlinux.org>
-# Contributor: Stéphane Gaudreault <stephane@archlinux.org>
+# Contributor: Stéphane Gaudreault <stephane@archlinux.org>
# Contributor: kevin <kevin@archlinux.org>
# Contributor: Giovanni Scafora <giovanni@archlinux.org>
# Contributor: Kritoke <kritoke@gamebox.net>
@@ -19,11 +21,22 @@ arch=(i486 i686 pentium4 'x86_64')
url="https://www.boost.org/"
license=('custom')
makedepends=('icu' 'python' 'python-numpy' 'bzip2' 'zlib' 'openmpi' 'zstd')
-source=(https://boostorg.jfrog.io/artifactory/main/release/$pkgver/source/$_srcname.tar.gz)
-sha256sums=('4b2136f98bdd1f5857f1c3dea9ac2018effe65286cf251534b6ae20cc45e1847')
+source=(https://boostorg.jfrog.io/artifactory/main/release/$pkgver/source/$_srcname.tar.gz
+ $pkgname-ublas-c++20-iterator.patch::https://github.com/boostorg/ublas/commit/a31e5cffa85f.patch)
+sha256sums=('4b2136f98bdd1f5857f1c3dea9ac2018effe65286cf251534b6ae20cc45e1847'
+ 'aa38addb40d5f44b4a8472029b475e7e6aef1c460509eb7d8edf03491dc1b5ee')
+
+prepare() {
+ cd $_srcname
+
+ # https://github.com/boostorg/ublas/pull/97
+ patch -Np2 -i ../$pkgname-ublas-c++20-iterator.patch
+}
build() {
local JOBS="$(sed 's/.*\(-j *[0-9]\+\).*/\1/' <<<$MAKEFLAGS)"
+ local python_version=$(
+ python -c 'import sys; print(".".join(map(str, sys.version_info[:2])))')
pushd $_srcname/tools/build
./bootstrap.sh --cxxflags="$CXXFLAGS $LDFLAGS"
@@ -49,7 +62,7 @@ build() {
runtime-link=shared \
link=shared,static \
toolset=gcc \
- python=3.10 \
+ python=$python_version \
cflags="$CPPFLAGS $CFLAGS -fPIC -O3 -ffat-lto-objects" \
cxxflags="$CPPFLAGS $CXXFLAGS -fPIC -O3 -ffat-lto-objects" \
linkflags="$LDFLAGS" \