Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-12-10 16:02:42 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2022-12-10 16:02:42 +0100
commit6e8373b4c6baaf388768b9eb6cff2ebfd4c868f8 (patch)
tree30f48de07cf212399c506d1f9ba0f78783e1d02e /community
parent76a5999ee024cc301c14a19f2cb3ea2b671e5848 (diff)
community/gcc11: fixed patching
Diffstat (limited to 'community')
-rw-r--r--community/gcc11/PKGBUILD19
1 files changed, 6 insertions, 13 deletions
diff --git a/community/gcc11/PKGBUILD b/community/gcc11/PKGBUILD
index 421ebf0e..4386fa71 100644
--- a/community/gcc11/PKGBUILD
+++ b/community/gcc11/PKGBUILD
@@ -17,25 +17,18 @@ eval "$(
/configure/ s,--with-bugurl=https://bugs\.archlinux\.org/,--with-bugurl=https://bugs.archlinux32.org/,
/configure/ s/;$/ --build=$CHOST;/
'
- declare -f package_gcc-libs | \
+ declare -f package_gcc11-libs | \
sed '
s/\$pkgname-multilib//
s@libsanitizer/{a,l,ub,t}san@libsanitizer/{a,l,ub}san@
/provides=/s/libtsan.so//
\@/usr/lib32/@ d
'
- declare -f package_gcc | \
+ declare -f package_gcc11 | \
sed '
s/"lib32-gcc-libs[^"]*"//g
s@make.*tsan.*install@#\0@
'
- declare -f package_gcc-ada | \
- sed '
- \,cd .*/32/libada,{
- N
- d
- }
- '
)"
eval "$(
for name in "${pkgname[@]}"; do
@@ -57,7 +50,7 @@ makedepends_i686+=('gcc-ada')
makedepends_pentium4+=('gcc-ada')
if [ "${CARCH}" = "i486" ]; then
- package_gcc-ada() {
+ package_gcc11-ada() {
touch "$pkgdir/this-is-a-dummy-package"
}
@@ -69,7 +62,7 @@ if [ "${CARCH}" = "i486" ]; then
)"
eval "$(
- declare -f package_gcc | \
+ declare -f package_gcc11 | \
sed '
s/,gnat-style,gnat_rm,gnat_ugn//
'
@@ -82,7 +75,7 @@ if [ "${CARCH}" = "i486" ]; then
# make: Leaving directory '/build/gcc/src/gcc-build/i486-pc-linux-gnu/libgfortran'
# => wrong link order: libgfortran requires libquadmath
eval "$(
- declare -f package_gcc-libs | \
+ declare -f package_gcc11-libs | \
sed '
/for lib in / s/libgfortran/libquadmath libgfortran/
'
@@ -121,7 +114,7 @@ if [ "${CARCH}" = "i486" ]; then
s/--enable-lto/--disable-lto/
s/--with-build-config=bootstrap-lto//
'
- declare -f package_gcc | \
+ declare -f package_gcc11 | \
sed '
/make.*lto-plugin.*install/d
/ln.*liblto_plugin.so/d