Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-10-08 12:38:58 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-10-08 12:38:58 +0200
commit426b293f55a6e3cf4c58db8d3553a330e861a42c (patch)
tree2103d5dd1f028ca345a80dd4d33457d7b782432c /community
parent61a6ea38af60b1ffc614ee954725c578b6ebe1aa (diff)
community/ruby: try to with /opt bootstrapping without conflicting ruby
Diffstat (limited to 'community')
-rw-r--r--community/ruby-abbrev/PKGBUILD5
-rw-r--r--community/ruby-base64/PKGBUILD5
-rw-r--r--community/ruby-benchmark/PKGBUILD5
-rw-r--r--community/ruby-bigdecimal/PKGBUILD5
-rw-r--r--community/ruby-bundler/PKGBUILD5
-rw-r--r--community/ruby-cgi/PKGBUILD5
-rw-r--r--community/ruby-csv/PKGBUILD7
-rw-r--r--community/ruby-date/PKGBUILD5
-rw-r--r--community/ruby-delegate/PKGBUILD5
-rw-r--r--community/ruby-did_you_mean/PKGBUILD5
-rw-r--r--community/ruby-digest/PKGBUILD4
-rw-r--r--community/ruby-drb/PKGBUILD5
-rw-r--r--community/ruby-english/PKGBUILD5
-rw-r--r--community/ruby-erb/PKGBUILD5
-rw-r--r--community/ruby-etc/PKGBUILD5
-rw-r--r--community/ruby-fcntl/PKGBUILD5
-rw-r--r--community/ruby-fiddle/PKGBUILD5
-rw-r--r--community/ruby-fileutils/PKGBUILD5
-rw-r--r--community/ruby-find/PKGBUILD5
-rw-r--r--community/ruby-forwardable/PKGBUILD5
-rw-r--r--community/ruby-getoptlong/PKGBUILD5
-rw-r--r--community/ruby-io-console/PKGBUILD5
-rw-r--r--community/ruby-io-nonblock/PKGBUILD5
-rw-r--r--community/ruby-io-wait/PKGBUILD5
-rw-r--r--community/ruby-ipaddr/PKGBUILD5
-rw-r--r--community/ruby-irb/PKGBUILD5
-rw-r--r--community/ruby-json/PKGBUILD5
-rw-r--r--community/ruby-logger/PKGBUILD5
-rw-r--r--community/ruby-minitest/PKGBUILD5
-rw-r--r--community/ruby-mutex_m/PKGBUILD5
-rw-r--r--community/ruby-net-http/PKGBUILD5
-rw-r--r--community/ruby-open-uri/PKGBUILD4
-rw-r--r--community/ruby-psych/PKGBUILD3
-rw-r--r--community/ruby-racc/PKGBUILD5
-rw-r--r--community/ruby-rake-compiler/PKGBUILD3
-rw-r--r--community/ruby-rake/PKGBUILD3
-rw-r--r--community/ruby-rdoc/PKGBUILD5
-rw-r--r--community/ruby-reline/PKGBUILD5
-rw-r--r--community/ruby-stringio/PKGBUILD5
-rw-r--r--community/ruby-time/PKGBUILD5
-rw-r--r--community/ruby-tmpdir/PKGBUILD5
-rw-r--r--community/ruby-uri/PKGBUILD5
42 files changed, 195 insertions, 9 deletions
diff --git a/community/ruby-abbrev/PKGBUILD b/community/ruby-abbrev/PKGBUILD
index c9fc0867..e4a5d80a 100644
--- a/community/ruby-abbrev/PKGBUILD
+++ b/community/ruby-abbrev/PKGBUILD
@@ -1,3 +1,7 @@
+# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
+# and depend on 'ruby'
+makedepends=(ruby-bootstrap)
+
# install to final destination in /usr and not into /opt/ruby-xxx
eval "$(
declare -f package | \
@@ -6,3 +10,4 @@ eval "$(
'
)"
+unset check
diff --git a/community/ruby-base64/PKGBUILD b/community/ruby-base64/PKGBUILD
index c9fc0867..e4a5d80a 100644
--- a/community/ruby-base64/PKGBUILD
+++ b/community/ruby-base64/PKGBUILD
@@ -1,3 +1,7 @@
+# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
+# and depend on 'ruby'
+makedepends=(ruby-bootstrap)
+
# install to final destination in /usr and not into /opt/ruby-xxx
eval "$(
declare -f package | \
@@ -6,3 +10,4 @@ eval "$(
'
)"
+unset check
diff --git a/community/ruby-benchmark/PKGBUILD b/community/ruby-benchmark/PKGBUILD
index c9fc0867..e4a5d80a 100644
--- a/community/ruby-benchmark/PKGBUILD
+++ b/community/ruby-benchmark/PKGBUILD
@@ -1,3 +1,7 @@
+# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
+# and depend on 'ruby'
+makedepends=(ruby-bootstrap)
+
# install to final destination in /usr and not into /opt/ruby-xxx
eval "$(
declare -f package | \
@@ -6,3 +10,4 @@ eval "$(
'
)"
+unset check
diff --git a/community/ruby-bigdecimal/PKGBUILD b/community/ruby-bigdecimal/PKGBUILD
index c9fc0867..e4a5d80a 100644
--- a/community/ruby-bigdecimal/PKGBUILD
+++ b/community/ruby-bigdecimal/PKGBUILD
@@ -1,3 +1,7 @@
+# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
+# and depend on 'ruby'
+makedepends=(ruby-bootstrap)
+
# install to final destination in /usr and not into /opt/ruby-xxx
eval "$(
declare -f package | \
@@ -6,3 +10,4 @@ eval "$(
'
)"
+unset check
diff --git a/community/ruby-bundler/PKGBUILD b/community/ruby-bundler/PKGBUILD
index c9fc0867..e4a5d80a 100644
--- a/community/ruby-bundler/PKGBUILD
+++ b/community/ruby-bundler/PKGBUILD
@@ -1,3 +1,7 @@
+# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
+# and depend on 'ruby'
+makedepends=(ruby-bootstrap)
+
# install to final destination in /usr and not into /opt/ruby-xxx
eval "$(
declare -f package | \
@@ -6,3 +10,4 @@ eval "$(
'
)"
+unset check
diff --git a/community/ruby-cgi/PKGBUILD b/community/ruby-cgi/PKGBUILD
index c9fc0867..e4a5d80a 100644
--- a/community/ruby-cgi/PKGBUILD
+++ b/community/ruby-cgi/PKGBUILD
@@ -1,3 +1,7 @@
+# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
+# and depend on 'ruby'
+makedepends=(ruby-bootstrap)
+
# install to final destination in /usr and not into /opt/ruby-xxx
eval "$(
declare -f package | \
@@ -6,3 +10,4 @@ eval "$(
'
)"
+unset check
diff --git a/community/ruby-csv/PKGBUILD b/community/ruby-csv/PKGBUILD
index 51518b4f..e4a5d80a 100644
--- a/community/ruby-csv/PKGBUILD
+++ b/community/ruby-csv/PKGBUILD
@@ -1,3 +1,7 @@
+# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
+# and depend on 'ruby'
+makedepends=(ruby-bootstrap)
+
# install to final destination in /usr and not into /opt/ruby-xxx
eval "$(
declare -f package | \
@@ -6,7 +10,4 @@ eval "$(
'
)"
-# Command failed with status (1): [/opt/ruby-bootstrap-3.0.4/bin/ruby run-tes...]
-# /build/ruby-csv/src/csv-3.2.5/Rakefile:10:in `block in <top (required)>'
-# Tasks: TOP => test
unset check
diff --git a/community/ruby-date/PKGBUILD b/community/ruby-date/PKGBUILD
index c9fc0867..e4a5d80a 100644
--- a/community/ruby-date/PKGBUILD
+++ b/community/ruby-date/PKGBUILD
@@ -1,3 +1,7 @@
+# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
+# and depend on 'ruby'
+makedepends=(ruby-bootstrap)
+
# install to final destination in /usr and not into /opt/ruby-xxx
eval "$(
declare -f package | \
@@ -6,3 +10,4 @@ eval "$(
'
)"
+unset check
diff --git a/community/ruby-delegate/PKGBUILD b/community/ruby-delegate/PKGBUILD
index c9fc0867..e4a5d80a 100644
--- a/community/ruby-delegate/PKGBUILD
+++ b/community/ruby-delegate/PKGBUILD
@@ -1,3 +1,7 @@
+# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
+# and depend on 'ruby'
+makedepends=(ruby-bootstrap)
+
# install to final destination in /usr and not into /opt/ruby-xxx
eval "$(
declare -f package | \
@@ -6,3 +10,4 @@ eval "$(
'
)"
+unset check
diff --git a/community/ruby-did_you_mean/PKGBUILD b/community/ruby-did_you_mean/PKGBUILD
index c9fc0867..e4a5d80a 100644
--- a/community/ruby-did_you_mean/PKGBUILD
+++ b/community/ruby-did_you_mean/PKGBUILD
@@ -1,3 +1,7 @@
+# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
+# and depend on 'ruby'
+makedepends=(ruby-bootstrap)
+
# install to final destination in /usr and not into /opt/ruby-xxx
eval "$(
declare -f package | \
@@ -6,3 +10,4 @@ eval "$(
'
)"
+unset check
diff --git a/community/ruby-digest/PKGBUILD b/community/ruby-digest/PKGBUILD
index 96018bae..f242438c 100644
--- a/community/ruby-digest/PKGBUILD
+++ b/community/ruby-digest/PKGBUILD
@@ -1,3 +1,7 @@
+# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
+# and depend on 'ruby'
+makedepends=(ruby-bootstrap)
+
# install to final destination in /usr and not into /opt/ruby-xxx
eval "$(
declare -f package | \
diff --git a/community/ruby-drb/PKGBUILD b/community/ruby-drb/PKGBUILD
index c9fc0867..e4a5d80a 100644
--- a/community/ruby-drb/PKGBUILD
+++ b/community/ruby-drb/PKGBUILD
@@ -1,3 +1,7 @@
+# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
+# and depend on 'ruby'
+makedepends=(ruby-bootstrap)
+
# install to final destination in /usr and not into /opt/ruby-xxx
eval "$(
declare -f package | \
@@ -6,3 +10,4 @@ eval "$(
'
)"
+unset check
diff --git a/community/ruby-english/PKGBUILD b/community/ruby-english/PKGBUILD
index c9fc0867..e4a5d80a 100644
--- a/community/ruby-english/PKGBUILD
+++ b/community/ruby-english/PKGBUILD
@@ -1,3 +1,7 @@
+# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
+# and depend on 'ruby'
+makedepends=(ruby-bootstrap)
+
# install to final destination in /usr and not into /opt/ruby-xxx
eval "$(
declare -f package | \
@@ -6,3 +10,4 @@ eval "$(
'
)"
+unset check
diff --git a/community/ruby-erb/PKGBUILD b/community/ruby-erb/PKGBUILD
index c9fc0867..e4a5d80a 100644
--- a/community/ruby-erb/PKGBUILD
+++ b/community/ruby-erb/PKGBUILD
@@ -1,3 +1,7 @@
+# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
+# and depend on 'ruby'
+makedepends=(ruby-bootstrap)
+
# install to final destination in /usr and not into /opt/ruby-xxx
eval "$(
declare -f package | \
@@ -6,3 +10,4 @@ eval "$(
'
)"
+unset check
diff --git a/community/ruby-etc/PKGBUILD b/community/ruby-etc/PKGBUILD
index c9fc0867..e4a5d80a 100644
--- a/community/ruby-etc/PKGBUILD
+++ b/community/ruby-etc/PKGBUILD
@@ -1,3 +1,7 @@
+# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
+# and depend on 'ruby'
+makedepends=(ruby-bootstrap)
+
# install to final destination in /usr and not into /opt/ruby-xxx
eval "$(
declare -f package | \
@@ -6,3 +10,4 @@ eval "$(
'
)"
+unset check
diff --git a/community/ruby-fcntl/PKGBUILD b/community/ruby-fcntl/PKGBUILD
index c9fc0867..e4a5d80a 100644
--- a/community/ruby-fcntl/PKGBUILD
+++ b/community/ruby-fcntl/PKGBUILD
@@ -1,3 +1,7 @@
+# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
+# and depend on 'ruby'
+makedepends=(ruby-bootstrap)
+
# install to final destination in /usr and not into /opt/ruby-xxx
eval "$(
declare -f package | \
@@ -6,3 +10,4 @@ eval "$(
'
)"
+unset check
diff --git a/community/ruby-fiddle/PKGBUILD b/community/ruby-fiddle/PKGBUILD
index 2e7db225..e4a5d80a 100644
--- a/community/ruby-fiddle/PKGBUILD
+++ b/community/ruby-fiddle/PKGBUILD
@@ -1,3 +1,7 @@
+# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
+# and depend on 'ruby'
+makedepends=(ruby-bootstrap)
+
# install to final destination in /usr and not into /opt/ruby-xxx
eval "$(
declare -f package | \
@@ -6,5 +10,4 @@ eval "$(
'
)"
-# tests are failing
unset check
diff --git a/community/ruby-fileutils/PKGBUILD b/community/ruby-fileutils/PKGBUILD
index c9fc0867..e4a5d80a 100644
--- a/community/ruby-fileutils/PKGBUILD
+++ b/community/ruby-fileutils/PKGBUILD
@@ -1,3 +1,7 @@
+# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
+# and depend on 'ruby'
+makedepends=(ruby-bootstrap)
+
# install to final destination in /usr and not into /opt/ruby-xxx
eval "$(
declare -f package | \
@@ -6,3 +10,4 @@ eval "$(
'
)"
+unset check
diff --git a/community/ruby-find/PKGBUILD b/community/ruby-find/PKGBUILD
index c9fc0867..e4a5d80a 100644
--- a/community/ruby-find/PKGBUILD
+++ b/community/ruby-find/PKGBUILD
@@ -1,3 +1,7 @@
+# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
+# and depend on 'ruby'
+makedepends=(ruby-bootstrap)
+
# install to final destination in /usr and not into /opt/ruby-xxx
eval "$(
declare -f package | \
@@ -6,3 +10,4 @@ eval "$(
'
)"
+unset check
diff --git a/community/ruby-forwardable/PKGBUILD b/community/ruby-forwardable/PKGBUILD
index c9fc0867..e4a5d80a 100644
--- a/community/ruby-forwardable/PKGBUILD
+++ b/community/ruby-forwardable/PKGBUILD
@@ -1,3 +1,7 @@
+# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
+# and depend on 'ruby'
+makedepends=(ruby-bootstrap)
+
# install to final destination in /usr and not into /opt/ruby-xxx
eval "$(
declare -f package | \
@@ -6,3 +10,4 @@ eval "$(
'
)"
+unset check
diff --git a/community/ruby-getoptlong/PKGBUILD b/community/ruby-getoptlong/PKGBUILD
index c9fc0867..e4a5d80a 100644
--- a/community/ruby-getoptlong/PKGBUILD
+++ b/community/ruby-getoptlong/PKGBUILD
@@ -1,3 +1,7 @@
+# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
+# and depend on 'ruby'
+makedepends=(ruby-bootstrap)
+
# install to final destination in /usr and not into /opt/ruby-xxx
eval "$(
declare -f package | \
@@ -6,3 +10,4 @@ eval "$(
'
)"
+unset check
diff --git a/community/ruby-io-console/PKGBUILD b/community/ruby-io-console/PKGBUILD
index c9fc0867..e4a5d80a 100644
--- a/community/ruby-io-console/PKGBUILD
+++ b/community/ruby-io-console/PKGBUILD
@@ -1,3 +1,7 @@
+# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
+# and depend on 'ruby'
+makedepends=(ruby-bootstrap)
+
# install to final destination in /usr and not into /opt/ruby-xxx
eval "$(
declare -f package | \
@@ -6,3 +10,4 @@ eval "$(
'
)"
+unset check
diff --git a/community/ruby-io-nonblock/PKGBUILD b/community/ruby-io-nonblock/PKGBUILD
index c9fc0867..e4a5d80a 100644
--- a/community/ruby-io-nonblock/PKGBUILD
+++ b/community/ruby-io-nonblock/PKGBUILD
@@ -1,3 +1,7 @@
+# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
+# and depend on 'ruby'
+makedepends=(ruby-bootstrap)
+
# install to final destination in /usr and not into /opt/ruby-xxx
eval "$(
declare -f package | \
@@ -6,3 +10,4 @@ eval "$(
'
)"
+unset check
diff --git a/community/ruby-io-wait/PKGBUILD b/community/ruby-io-wait/PKGBUILD
index c9fc0867..e4a5d80a 100644
--- a/community/ruby-io-wait/PKGBUILD
+++ b/community/ruby-io-wait/PKGBUILD
@@ -1,3 +1,7 @@
+# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
+# and depend on 'ruby'
+makedepends=(ruby-bootstrap)
+
# install to final destination in /usr and not into /opt/ruby-xxx
eval "$(
declare -f package | \
@@ -6,3 +10,4 @@ eval "$(
'
)"
+unset check
diff --git a/community/ruby-ipaddr/PKGBUILD b/community/ruby-ipaddr/PKGBUILD
index c9fc0867..e4a5d80a 100644
--- a/community/ruby-ipaddr/PKGBUILD
+++ b/community/ruby-ipaddr/PKGBUILD
@@ -1,3 +1,7 @@
+# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
+# and depend on 'ruby'
+makedepends=(ruby-bootstrap)
+
# install to final destination in /usr and not into /opt/ruby-xxx
eval "$(
declare -f package | \
@@ -6,3 +10,4 @@ eval "$(
'
)"
+unset check
diff --git a/community/ruby-irb/PKGBUILD b/community/ruby-irb/PKGBUILD
index ac5587be..e4a5d80a 100644
--- a/community/ruby-irb/PKGBUILD
+++ b/community/ruby-irb/PKGBUILD
@@ -1,3 +1,7 @@
+# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
+# and depend on 'ruby'
+makedepends=(ruby-bootstrap)
+
# install to final destination in /usr and not into /opt/ruby-xxx
eval "$(
declare -f package | \
@@ -6,5 +10,4 @@ eval "$(
'
)"
-# hangs sometimes
unset check
diff --git a/community/ruby-json/PKGBUILD b/community/ruby-json/PKGBUILD
index c9fc0867..e4a5d80a 100644
--- a/community/ruby-json/PKGBUILD
+++ b/community/ruby-json/PKGBUILD
@@ -1,3 +1,7 @@
+# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
+# and depend on 'ruby'
+makedepends=(ruby-bootstrap)
+
# install to final destination in /usr and not into /opt/ruby-xxx
eval "$(
declare -f package | \
@@ -6,3 +10,4 @@ eval "$(
'
)"
+unset check
diff --git a/community/ruby-logger/PKGBUILD b/community/ruby-logger/PKGBUILD
index c9fc0867..e4a5d80a 100644
--- a/community/ruby-logger/PKGBUILD
+++ b/community/ruby-logger/PKGBUILD
@@ -1,3 +1,7 @@
+# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
+# and depend on 'ruby'
+makedepends=(ruby-bootstrap)
+
# install to final destination in /usr and not into /opt/ruby-xxx
eval "$(
declare -f package | \
@@ -6,3 +10,4 @@ eval "$(
'
)"
+unset check
diff --git a/community/ruby-minitest/PKGBUILD b/community/ruby-minitest/PKGBUILD
index c9fc0867..e4a5d80a 100644
--- a/community/ruby-minitest/PKGBUILD
+++ b/community/ruby-minitest/PKGBUILD
@@ -1,3 +1,7 @@
+# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
+# and depend on 'ruby'
+makedepends=(ruby-bootstrap)
+
# install to final destination in /usr and not into /opt/ruby-xxx
eval "$(
declare -f package | \
@@ -6,3 +10,4 @@ eval "$(
'
)"
+unset check
diff --git a/community/ruby-mutex_m/PKGBUILD b/community/ruby-mutex_m/PKGBUILD
index c9fc0867..e4a5d80a 100644
--- a/community/ruby-mutex_m/PKGBUILD
+++ b/community/ruby-mutex_m/PKGBUILD
@@ -1,3 +1,7 @@
+# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
+# and depend on 'ruby'
+makedepends=(ruby-bootstrap)
+
# install to final destination in /usr and not into /opt/ruby-xxx
eval "$(
declare -f package | \
@@ -6,3 +10,4 @@ eval "$(
'
)"
+unset check
diff --git a/community/ruby-net-http/PKGBUILD b/community/ruby-net-http/PKGBUILD
index a01e4938..e4a5d80a 100644
--- a/community/ruby-net-http/PKGBUILD
+++ b/community/ruby-net-http/PKGBUILD
@@ -1,3 +1,7 @@
+# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
+# and depend on 'ruby'
+makedepends=(ruby-bootstrap)
+
# install to final destination in /usr and not into /opt/ruby-xxx
eval "$(
declare -f package | \
@@ -6,5 +10,4 @@ eval "$(
'
)"
-# disable tests during bootstrapping
unset check
diff --git a/community/ruby-open-uri/PKGBUILD b/community/ruby-open-uri/PKGBUILD
index 4a1cc29b..e4a5d80a 100644
--- a/community/ruby-open-uri/PKGBUILD
+++ b/community/ruby-open-uri/PKGBUILD
@@ -1,3 +1,7 @@
+# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
+# and depend on 'ruby'
+makedepends=(ruby-bootstrap)
+
# install to final destination in /usr and not into /opt/ruby-xxx
eval "$(
declare -f package | \
diff --git a/community/ruby-psych/PKGBUILD b/community/ruby-psych/PKGBUILD
index 9a1a2c83..e4a5d80a 100644
--- a/community/ruby-psych/PKGBUILD
+++ b/community/ruby-psych/PKGBUILD
@@ -1,6 +1,6 @@
# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
# and depend on 'ruby'
-makedepends+=(ruby-bootstrap)
+makedepends=(ruby-bootstrap)
# install to final destination in /usr and not into /opt/ruby-xxx
eval "$(
@@ -10,3 +10,4 @@ eval "$(
'
)"
+unset check
diff --git a/community/ruby-racc/PKGBUILD b/community/ruby-racc/PKGBUILD
index c9fc0867..e4a5d80a 100644
--- a/community/ruby-racc/PKGBUILD
+++ b/community/ruby-racc/PKGBUILD
@@ -1,3 +1,7 @@
+# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
+# and depend on 'ruby'
+makedepends=(ruby-bootstrap)
+
# install to final destination in /usr and not into /opt/ruby-xxx
eval "$(
declare -f package | \
@@ -6,3 +10,4 @@ eval "$(
'
)"
+unset check
diff --git a/community/ruby-rake-compiler/PKGBUILD b/community/ruby-rake-compiler/PKGBUILD
index 80f7a4ab..67fe250e 100644
--- a/community/ruby-rake-compiler/PKGBUILD
+++ b/community/ruby-rake-compiler/PKGBUILD
@@ -1,7 +1,6 @@
# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
# and depend on 'ruby'
makedepends+=(ruby-bootstrap)
-depends=()
# install to final destination in /usr and not into /opt/ruby-xxx
eval "$(
@@ -11,3 +10,5 @@ eval "$(
/_gemdir/ a mkdir -p "${pkgdir}"/usr/bin/
'
)"
+
+unset check
diff --git a/community/ruby-rake/PKGBUILD b/community/ruby-rake/PKGBUILD
index 80f7a4ab..67fe250e 100644
--- a/community/ruby-rake/PKGBUILD
+++ b/community/ruby-rake/PKGBUILD
@@ -1,7 +1,6 @@
# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
# and depend on 'ruby'
makedepends+=(ruby-bootstrap)
-depends=()
# install to final destination in /usr and not into /opt/ruby-xxx
eval "$(
@@ -11,3 +10,5 @@ eval "$(
/_gemdir/ a mkdir -p "${pkgdir}"/usr/bin/
'
)"
+
+unset check
diff --git a/community/ruby-rdoc/PKGBUILD b/community/ruby-rdoc/PKGBUILD
index c9fc0867..e4a5d80a 100644
--- a/community/ruby-rdoc/PKGBUILD
+++ b/community/ruby-rdoc/PKGBUILD
@@ -1,3 +1,7 @@
+# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
+# and depend on 'ruby'
+makedepends=(ruby-bootstrap)
+
# install to final destination in /usr and not into /opt/ruby-xxx
eval "$(
declare -f package | \
@@ -6,3 +10,4 @@ eval "$(
'
)"
+unset check
diff --git a/community/ruby-reline/PKGBUILD b/community/ruby-reline/PKGBUILD
index c9fc0867..e4a5d80a 100644
--- a/community/ruby-reline/PKGBUILD
+++ b/community/ruby-reline/PKGBUILD
@@ -1,3 +1,7 @@
+# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
+# and depend on 'ruby'
+makedepends=(ruby-bootstrap)
+
# install to final destination in /usr and not into /opt/ruby-xxx
eval "$(
declare -f package | \
@@ -6,3 +10,4 @@ eval "$(
'
)"
+unset check
diff --git a/community/ruby-stringio/PKGBUILD b/community/ruby-stringio/PKGBUILD
index c9fc0867..e4a5d80a 100644
--- a/community/ruby-stringio/PKGBUILD
+++ b/community/ruby-stringio/PKGBUILD
@@ -1,3 +1,7 @@
+# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
+# and depend on 'ruby'
+makedepends=(ruby-bootstrap)
+
# install to final destination in /usr and not into /opt/ruby-xxx
eval "$(
declare -f package | \
@@ -6,3 +10,4 @@ eval "$(
'
)"
+unset check
diff --git a/community/ruby-time/PKGBUILD b/community/ruby-time/PKGBUILD
index c9fc0867..e4a5d80a 100644
--- a/community/ruby-time/PKGBUILD
+++ b/community/ruby-time/PKGBUILD
@@ -1,3 +1,7 @@
+# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
+# and depend on 'ruby'
+makedepends=(ruby-bootstrap)
+
# install to final destination in /usr and not into /opt/ruby-xxx
eval "$(
declare -f package | \
@@ -6,3 +10,4 @@ eval "$(
'
)"
+unset check
diff --git a/community/ruby-tmpdir/PKGBUILD b/community/ruby-tmpdir/PKGBUILD
index c9fc0867..e4a5d80a 100644
--- a/community/ruby-tmpdir/PKGBUILD
+++ b/community/ruby-tmpdir/PKGBUILD
@@ -1,3 +1,7 @@
+# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
+# and depend on 'ruby'
+makedepends=(ruby-bootstrap)
+
# install to final destination in /usr and not into /opt/ruby-xxx
eval "$(
declare -f package | \
@@ -6,3 +10,4 @@ eval "$(
'
)"
+unset check
diff --git a/community/ruby-uri/PKGBUILD b/community/ruby-uri/PKGBUILD
index c9fc0867..e4a5d80a 100644
--- a/community/ruby-uri/PKGBUILD
+++ b/community/ruby-uri/PKGBUILD
@@ -1,3 +1,7 @@
+# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
+# and depend on 'ruby'
+makedepends=(ruby-bootstrap)
+
# install to final destination in /usr and not into /opt/ruby-xxx
eval "$(
declare -f package | \
@@ -6,3 +10,4 @@ eval "$(
'
)"
+unset check