Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-10-09 08:46:58 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-10-09 08:46:58 +0200
commit2ae3bc2ee9ced1c7ad803a1dba58e6902b4d058d (patch)
tree5588b6ca5c577feac022115e814d4fa304ede790 /community
parentdb7d205c818be6b406f2626a9ad8e03bee455c49 (diff)
community/ruby-digest: rebuilding against ruby with patching for finding shared libraries
Diffstat (limited to 'community')
-rw-r--r--community/ruby-digest/PKGBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/community/ruby-digest/PKGBUILD b/community/ruby-digest/PKGBUILD
index f242438c..6285a5a7 100644
--- a/community/ruby-digest/PKGBUILD
+++ b/community/ruby-digest/PKGBUILD
@@ -1,16 +1,19 @@
-# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
-# and depend on 'ruby'
-makedepends=(ruby-bootstrap)
-
-# install to final destination in /usr and not into /opt/ruby-xxx
+# bootstrapped packages in first step from /opt/ruby- contain
+# /opt/ruby-XXX/bin in the binaries in /usr/bin and they have
+# wrong architecture strings in native library code
+eval "$(
+ declare -f build | \
+ sed '
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
+ '
+)"
eval "$(
declare -f package | \
sed '
- s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
# break test circle of dependencies on ourselves.. ;-)
checkdepends=(${checkdepends[@]//ruby-digest/})
unset check
-