Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-10-09 14:32:03 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-10-09 14:32:03 +0200
commit238356ec5918f8f6b83d490b69f43e83e05cb668 (patch)
treeb14e724cfd34c8585c8f9810d6e558c6e652f9cf /community
parentbc651a024f6c695fe2cb4a31c32179ab9bc29bb1 (diff)
community/ruby-hoe: building using ruby-stdlib instead of build-support
Diffstat (limited to 'community')
-rw-r--r--community/ruby-hoe/PKGBUILD17
1 files changed, 17 insertions, 0 deletions
diff --git a/community/ruby-hoe/PKGBUILD b/community/ruby-hoe/PKGBUILD
new file mode 100644
index 00000000..472071e2
--- /dev/null
+++ b/community/ruby-hoe/PKGBUILD
@@ -0,0 +1,17 @@
+# bootstrapped packages in first step from /opt/ruby- contain
+# /opt/ruby-XXX/bin in the binaries in /usr/bin and they have
+# wrong architecture strings in native library code
+eval "$(
+ declare -f build | \
+ sed '
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
+ '
+)"
+eval "$(
+ declare -f package | \
+ sed '
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
+ '
+)"
+
+unset check