Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2023-05-11 16:17:56 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2023-05-11 16:17:56 +0200
commit1d4c7bf88bec357d5e9c4d21dabc46e51ec3617b (patch)
tree4c0e124e3dd81b5090395c7e356d4121eb01f20e /community
parent0d81a1e6bd742d4bfa437720de55c448a6115967 (diff)
community/python-build: bootstrapping for python 3.11
Diffstat (limited to 'community')
-rw-r--r--community/python-build/PKGBUILD8
1 files changed, 8 insertions, 0 deletions
diff --git a/community/python-build/PKGBUILD b/community/python-build/PKGBUILD
index 7b473826..125d6731 100644
--- a/community/python-build/PKGBUILD
+++ b/community/python-build/PKGBUILD
@@ -15,3 +15,11 @@ eval "$(
/.*\/share\/doc.*/d
'
)"
+
+# temporary to build python-build with python-bootstrap (breaking cycles)
+makedepends=(${makedepends[@]//python-installer/})
+makedepends=(${makedepends[@]//python-build/})
+makedepends=(${makedepends[@]//python-flit-core/})
+makedepends+=('python-bootstrap')
+unset checkdepends
+unset check