Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-10-06 20:13:27 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-10-06 20:13:27 +0200
commit15f745bc46dd0bd9165c0759e406bc8444cf6d5c (patch)
tree90b7a5f9a60eaef7b6ad67410f532982bf7e81fb /community
parentf10e13644a29cef2beb2c7b0a8633c08531a39f4 (diff)
community/ruby-$i: bootstrapping
Diffstat (limited to 'community')
-rw-r--r--community/ruby-reline/PKGBUILD12
1 files changed, 12 insertions, 0 deletions
diff --git a/community/ruby-reline/PKGBUILD b/community/ruby-reline/PKGBUILD
new file mode 100644
index 00000000..f41379db
--- /dev/null
+++ b/community/ruby-reline/PKGBUILD
@@ -0,0 +1,12 @@
+# bootstrapping with ruby-bootstrap in /opt/ruby-xxx
+depends=(${depends[@]//ruby/})
+depends+='ruby-bootstrap'
+
+# install to final destination in /usr and not into /opt/ruby-xxx
+eval "$(
+ declare -f package | \
+ sed '
+ s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
+ '
+)"
+