Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2020-07-25 18:44:10 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2020-07-25 18:44:10 +0200
commit141e351d1cafff2f23aaed174cb8e23c608031e3 (patch)
tree2ddd65d8db228d472abfec7f8ed333eada76db11 /community
parent0a2e3b3a20aa0d5eb4d10121a767ee96519db0cb (diff)
community/seamonkey: avoid GNU ld running out of memory
Diffstat (limited to 'community')
-rw-r--r--community/seamonkey/PKGBUILD8
1 files changed, 8 insertions, 0 deletions
diff --git a/community/seamonkey/PKGBUILD b/community/seamonkey/PKGBUILD
new file mode 100644
index 00000000..e4c017a8
--- /dev/null
+++ b/community/seamonkey/PKGBUILD
@@ -0,0 +1,8 @@
+# avoid memory exhaustion in GNU linker
+eval "$(
+ declare -f build | \
+ sed '
+ /make/ i \
+ export LDFLAGS="-Wl,--no-keep-memory"
+ '
+)"