Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2023-05-12 18:32:21 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2023-05-12 18:32:21 +0200
commit04054e4b51224a8b2dbc3196ba5437bcf5eab30c (patch)
treed6952dcce862aa4914bced06bb57753df62825a1 /community
parentcb064f8a9c3f713891653766735c6947270d7e0c (diff)
community/python-installer: rebuild
Diffstat (limited to 'community')
-rw-r--r--community/python-installer/PKGBUILD15
1 files changed, 12 insertions, 3 deletions
diff --git a/community/python-installer/PKGBUILD b/community/python-installer/PKGBUILD
index 9bc50ae4..6dd1a147 100644
--- a/community/python-installer/PKGBUILD
+++ b/community/python-installer/PKGBUILD
@@ -1,7 +1,8 @@
# breaking the cycle with python-spinx
-makedepends=(${makedepends[@]/python-sphinx-furo})
-makedepends=(${makedepends[@]/python-sphinx-argparse})
-makedepends=(${makedepends[@]/python-sphinx})
+makedepends=(${makedepends[@]//python-sphinx-furo})
+makedepends=(${makedepends[@]//python-sphinx-argparse})
+makedepends=(${makedepends[@]//python-sphinx})
+makedepends=(${makedepends[@]//python-myst-parser/})
eval "$(
declare -f build | \
sed '
@@ -12,3 +13,11 @@ eval "$(
/docs\/build\/html/d
'
)"
+
+# temporary to build python-build with python-bootstrap (breaking cycles)
+makedepends=(${makedepends[@]//python-installer/})
+makedepends=(${makedepends[@]//python-build/})
+makedepends=(${makedepends[@]//python-flit-core/})
+makedepends+=('python-bootstrap')
+unset checkdepends
+unset check