Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community/xaos
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2023-05-22 20:18:50 +0200
committerErich Eckner <git@eckner.net>2023-05-22 20:18:50 +0200
commite74cde76c104df82b120a7b13964cb786da8f565 (patch)
tree39967e24037929c04aaf79922aa260b437a60a5e /community/xaos
parent73e1d3b448cc583ab38cae4d61a26f313fad946b (diff)
community -> extra
Diffstat (limited to 'community/xaos')
-rw-r--r--community/xaos/PKGBUILD14
-rw-r--r--community/xaos/xaos.patch22
2 files changed, 0 insertions, 36 deletions
diff --git a/community/xaos/PKGBUILD b/community/xaos/PKGBUILD
deleted file mode 100644
index 15dd3e6c..00000000
--- a/community/xaos/PKGBUILD
+++ /dev/null
@@ -1,14 +0,0 @@
-source+=('xaos.patch')
-sha256sums+=('b07cdc88be38a30a40bccc2f999bff50ae8a25fc10ed4f2f7c7e2ff117f085e5')
-
-eval "$(
- {
- declare -f prepare || \
- printf 'prepare() {\n}\n'
- } \
- | sed '
- $i patch -p1 -N -i "$srcdir/xaos.patch" -d "$srcdir/$pkgname-$pkgver" \
- gendesk -f -n --pkgname=$pkgname --pkgdesc="$pkgdesc" \\\
- --categories='"'"'Application;Graphics'"'"'
- '
-)"
diff --git a/community/xaos/xaos.patch b/community/xaos/xaos.patch
deleted file mode 100644
index 7f29f57a..00000000
--- a/community/xaos/xaos.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-diff --unified --recursive --text xaos-3.6.orig/src/engine/zoom.c xaos-3.6.new/src/engine/zoom.c
---- xaos-3.6.orig/src/engine/zoom.c 2013-11-01 08:54:21.000000000 +0100
-+++ xaos-3.6.new/src/engine/zoom.c 2019-11-03 12:19:31.569988390 +0100
-@@ -933,6 +933,7 @@
- }
-
- #ifndef USE_i386ASM
-+REGISTERS(0)
- static /*INLINE */ void
- moveoldpoints(void /*@unused@ */ *data1,
- struct taskinfo /*@unused@ */ *task,
-diff --unified --recursive --text xaos-3.6.orig/src/engine/zoomd.c xaos-3.6.new/src/engine/zoomd.c
---- xaos-3.6.orig/src/engine/zoomd.c 2013-11-01 08:54:21.000000000 +0100
-+++ xaos-3.6.new/src/engine/zoomd.c 2019-11-03 12:19:39.910033088 +0100
-@@ -280,6 +280,7 @@
- #endif
- #undef bpp1
-
-+REGISTERS(0)
- static INLINE void fillline(int line)
- {
- register unsigned char *RESTRICT vbuff = cimage.currlines[line];