Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community/sarg
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2023-05-22 20:18:50 +0200
committerErich Eckner <git@eckner.net>2023-05-22 20:18:50 +0200
commite74cde76c104df82b120a7b13964cb786da8f565 (patch)
tree39967e24037929c04aaf79922aa260b437a60a5e /community/sarg
parent73e1d3b448cc583ab38cae4d61a26f313fad946b (diff)
community -> extra
Diffstat (limited to 'community/sarg')
-rw-r--r--community/sarg/PKGBUILD8
-rw-r--r--community/sarg/no-werror.patch23
2 files changed, 0 insertions, 31 deletions
diff --git a/community/sarg/PKGBUILD b/community/sarg/PKGBUILD
deleted file mode 100644
index 6c188a3b..00000000
--- a/community/sarg/PKGBUILD
+++ /dev/null
@@ -1,8 +0,0 @@
-source+=(no-werror.patch)
-sha256sums+=(42744656ddc442d7823859f170750c4b69e5dc599230218dd3016f7a74809a4d)
-eval "$(
- declare -f prepare \
- | sed '
- $ i patch -p1 -i "$srcdir"/no-werror.patch
- '
-)"
diff --git a/community/sarg/no-werror.patch b/community/sarg/no-werror.patch
deleted file mode 100644
index 7d04349b..00000000
--- a/community/sarg/no-werror.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index aac6933..aa784ea 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -71,18 +71,6 @@ IF(HAVE_WEXTRA)
- SET_TARGET_PROPERTIES(sarg PROPERTIES COMPILE_FLAGS "${TMPCFLAGS} -Wextra -Wno-unused-parameter")
- ENDIF(HAVE_WEXTRA)
-
--CHECK_C_COMPILER_FLAG("-Werror=implicit-function-declaration" HAVE_WERROR_IMPLICIT_FUNCTION)
--IF(HAVE_WERROR_IMPLICIT_FUNCTION)
-- GET_TARGET_PROPERTY(TMPCFLAGS sarg COMPILE_FLAGS)
-- SET_TARGET_PROPERTIES(sarg PROPERTIES COMPILE_FLAGS "${TMPCFLAGS} -Werror=implicit-function-declaration")
--ENDIF(HAVE_WERROR_IMPLICIT_FUNCTION)
--
--CHECK_C_COMPILER_FLAG("-Werror=format" HAVE_WERROR_FORMAT)
--IF(HAVE_WERROR_FORMAT)
-- GET_TARGET_PROPERTY(TMPCFLAGS sarg COMPILE_FLAGS)
-- SET_TARGET_PROPERTIES(sarg PROPERTIES COMPILE_FLAGS "${TMPCFLAGS} -Werror=format")
--ENDIF(HAVE_WERROR_FORMAT)
--
- # Required header files
- CHECK_INCLUDE_FILE(stdio.h HAVE_STDIO_H)
- CHECK_INCLUDE_FILE(stdlib.h HAVE_STDLIB_H)