Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community/ruby-rake
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-10-06 15:09:27 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-10-06 15:09:27 +0200
commitc40b624a1eb0ba5f181add4ff5fdd367fa85d179 (patch)
treede6079ab16e9f1328aeabf8d042c1e1e8bd92241 /community/ruby-rake
parent9e3481f19633a13f2e87bd2807bc2f3c53db08ab (diff)
community/ruby-rake: bootstrapping
Diffstat (limited to 'community/ruby-rake')
-rw-r--r--community/ruby-rake/PKGBUILD12
1 files changed, 12 insertions, 0 deletions
diff --git a/community/ruby-rake/PKGBUILD b/community/ruby-rake/PKGBUILD
new file mode 100644
index 00000000..f41379db
--- /dev/null
+++ b/community/ruby-rake/PKGBUILD
@@ -0,0 +1,12 @@
+# bootstrapping with ruby-bootstrap in /opt/ruby-xxx
+depends=(${depends[@]//ruby/})
+depends+='ruby-bootstrap'
+
+# install to final destination in /usr and not into /opt/ruby-xxx
+eval "$(
+ declare -f package | \
+ sed '
+ s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
+ '
+)"
+