Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community/ruby-digest/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-10-06 19:21:14 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-10-06 19:21:14 +0200
commit1dcfa63b6b0c59f3b2286f185e8849c07b888462 (patch)
tree15e2a7d188a4459d0a3fdc0f1ed2b7469c90ba6d /community/ruby-digest/PKGBUILD
parent44979b957a9829f7f0967abdcbd49922642cc818 (diff)
community/ruby-digest: bootstrapping
Diffstat (limited to 'community/ruby-digest/PKGBUILD')
-rw-r--r--community/ruby-digest/PKGBUILD16
1 files changed, 16 insertions, 0 deletions
diff --git a/community/ruby-digest/PKGBUILD b/community/ruby-digest/PKGBUILD
new file mode 100644
index 00000000..5fc94708
--- /dev/null
+++ b/community/ruby-digest/PKGBUILD
@@ -0,0 +1,16 @@
+# bootstrapping with ruby-bootstrap in /opt/ruby-xxx
+depends=(${depends[@]//ruby/})
+depends+='ruby-bootstrap'
+
+# install to final destination in /usr and not into /opt/ruby-xxx
+eval "$(
+ declare -f package | \
+ sed '
+ s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
+ '
+)"
+
+# break test circle of dependencies on ourselves.. ;-)
+checkdepends=(${checkdepends[@]//ruby-digest/})
+unset check
+