Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community/ruby-benchmark
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-10-06 15:33:44 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-10-06 15:33:44 +0200
commitfd2fbf9931eea0eba7cd24c55d50a395115eb10a (patch)
tree43802ecc84461d681247fa6008308cda28c89220 /community/ruby-benchmark
parentde881b00b4cf7126eb06d2fca89c4243f1715303 (diff)
community/ruby-benchmark: bootstrapping
Diffstat (limited to 'community/ruby-benchmark')
-rw-r--r--community/ruby-benchmark/PKGBUILD12
1 files changed, 12 insertions, 0 deletions
diff --git a/community/ruby-benchmark/PKGBUILD b/community/ruby-benchmark/PKGBUILD
new file mode 100644
index 00000000..f41379db
--- /dev/null
+++ b/community/ruby-benchmark/PKGBUILD
@@ -0,0 +1,12 @@
+# bootstrapping with ruby-bootstrap in /opt/ruby-xxx
+depends=(${depends[@]//ruby/})
+depends+='ruby-bootstrap'
+
+# install to final destination in /usr and not into /opt/ruby-xxx
+eval "$(
+ declare -f package | \
+ sed '
+ s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
+ '
+)"
+