Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community/libgda
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2023-05-22 20:18:50 +0200
committerErich Eckner <git@eckner.net>2023-05-22 20:18:50 +0200
commite74cde76c104df82b120a7b13964cb786da8f565 (patch)
tree39967e24037929c04aaf79922aa260b437a60a5e /community/libgda
parent73e1d3b448cc583ab38cae4d61a26f313fad946b (diff)
community -> extra
Diffstat (limited to 'community/libgda')
-rw-r--r--community/libgda/PKGBUILD26
-rw-r--r--community/libgda/java.patch36
2 files changed, 0 insertions, 62 deletions
diff --git a/community/libgda/PKGBUILD b/community/libgda/PKGBUILD
deleted file mode 100644
index 8ec2208e..00000000
--- a/community/libgda/PKGBUILD
+++ /dev/null
@@ -1,26 +0,0 @@
-# backported java probing patch for i386
-source+=('java.patch')
-sha256sums+=('e28ea88d49bcb91fa6907440a6785a508fb681c463188b3805509773f5d0fc22')
-
-eval "$(
- declare -f prepare | \
- sed '
- /autogen/ i \
- patch -Np1 -i "$srcdir/java.patch" \
- javac getsp.java
- '
-)"
-
-# no firebird
-eval "$(
- declare -f package_libgda | \
- sed '
- /provider/s/firebird//
- '
- declare -f package_libgda-firebird | \
- sed '
- 3 i if false; then
- $ i fi
- '
-)
-"
diff --git a/community/libgda/java.patch b/community/libgda/java.patch
deleted file mode 100644
index 7f12c5ad..00000000
--- a/community/libgda/java.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-diff -u -r libgda-5.2.4/getsp.java libgda-5.2.4-java/getsp.java
---- libgda-5.2.4/getsp.java 2014-02-05 21:28:20.000000000 +0100
-+++ libgda-5.2.4-java/getsp.java 2015-06-14 20:27:35.770310228 +0200
-@@ -25,7 +25,7 @@
- while (i<=j) {
- if (i==j || lp.charAt(i)==ps) {
- String lib=lp.substring(k,i);
-- String suffix="/lib/amd64/server";
-+ String suffix="/lib/"+System.getProperty("os.arch")+"/server";
- k=i+1;
- if (lib.compareTo(".")!=0)
- r=(r==null)?(prefix+lib+suffix):(r+" "+prefix+lib+suffix);
-@@ -50,7 +50,7 @@
-
- if (r!=null) System.out.println(r);
- } else if (args[0].compareTo("-ldpath")==0) {
-- String lp1=System.getProperty("java.home")+"/lib/amd64/server";
-+ String lp1=System.getProperty("java.home")+"/lib/"+System.getProperty("os.arch")+"/server";
- String lp2=System.getProperty("java.library.path");
- System.out.println(lp1+":"+lp2);
- }
-diff -u -r libgda-5.2.4/m4/java.m4 libgda-5.2.4-java/m4/java.m4
---- libgda-5.2.4/m4/java.m4 2015-06-13 10:36:25.000000000 +0200
-+++ libgda-5.2.4-java/m4/java.m4 2015-06-14 20:16:59.865581930 +0200
-@@ -175,6 +175,11 @@
- JTYPE="Sun JRE 1.7"
- JFLAGS="-Xlint:unchecked -Xlint:deprecation"
- ;;
-+ JRE1.8.*)
-+ try_java=true
-+ JTYPE="Sun JRE 1.8"
-+ JFLAGS="-Xlint:unchecked -Xlint:deprecation"
-+ ;;
- JREgcj-4*)
- try_java=true
- JTYPE="GCJ"