Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community/ksh
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2019-07-26 10:45:35 +0200
committerErich Eckner <git@eckner.net>2019-07-26 10:45:35 +0200
commitfd6b5fb3d55d6ee83c61e31d19ab52621219b8ad (patch)
tree3e9dec819d1943b5e4579a89bdb1b40351b9308c /community/ksh
parented7e1d0addba365abd7f9c35e1b9d8923be8d80a (diff)
community/ksh: ignore uname test results on i486
Diffstat (limited to 'community/ksh')
-rw-r--r--community/ksh/PKGBUILD9
1 files changed, 9 insertions, 0 deletions
diff --git a/community/ksh/PKGBUILD b/community/ksh/PKGBUILD
new file mode 100644
index 00000000..5dbc0b05
--- /dev/null
+++ b/community/ksh/PKGBUILD
@@ -0,0 +1,9 @@
+# on i486, uname reports the wrong architecture, so tests fail
+if [ "${CARCH}" = 'i486' ]; then
+ eval "$(
+ declare -f check \
+ | sed '
+ /meson test/ s/$/ || true; ! grep -vwF uname meson-logs/testlog.txt | grep -qwF FAIL
+ '
+ )"
+fi