Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community/clementine/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-09-25 12:03:09 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-09-25 12:03:09 +0200
commit1d93faea9d0d08a0bdc7d76f417ed0e04910628a (patch)
treefd58c18af87892d3ddc93c758b8ba903833c0c77 /community/clementine/PKGBUILD
parent320eb28d3b06a4e5b7eac4798d851b1318ed28f9 (diff)
community/clementine: using 1.4.0rc1 and patched qpainterpath
Diffstat (limited to 'community/clementine/PKGBUILD')
-rw-r--r--community/clementine/PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/community/clementine/PKGBUILD b/community/clementine/PKGBUILD
new file mode 100644
index 00000000..328858fa
--- /dev/null
+++ b/community/clementine/PKGBUILD
@@ -0,0 +1,24 @@
+# rc2 disappeared, we have to rebuild because of protobuf
+sed -i '
+ s/^pkgver=1.4.0rc2$/pkgver=1.4.0rc1/
+' PKGBUILD
+sha256sums[0]='96ba2f5f3ece47b2c1065e980dcc37ada93ea42cf37b794ee804514ce4a65459'
+
+# disable -Werror
+eval "$(
+ declare -f build | \
+ sed '
+ s|cmake -B build |cmake -B build -DBUILD_WERROR=OFF |
+ '
+)"
+
+# RC1 misses includes to QPainterPath
+source+=('clementine-1.4.0rc1-qpainterpath-missing-include.patch')
+sha256sums+=('64d538336a4f017abf1c6efa0973fc95eb1ac44aaf510b7c1e8a041113e1cdfd')
+eval "$(
+ declare -f prepare \
+ | sed '
+ $ i cd $pkgname-$pkgver
+ $ i patch -Np1 -i "$srcdir"/clementine-1.4.0rc1-qpainterpath-missing-include.patch
+ '
+)"