Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/build-support
diff options
context:
space:
mode:
authorTasos Sahanidis <tasos@tasossah.com>2024-01-12 08:20:56 +0000
committerTasos Sahanidis <tasos@tasossah.com>2024-01-12 10:22:42 +0200
commitf6708cd6ad0fb8f749eba6e215840998527a7e4b (patch)
treee4733c38809424799a68c96d49e2dfb2f6ae202a /build-support
parentae98a40b1e71819b4a2129276ff4c71129e4b5df (diff)
build-support/python-bootstrap: Add python-calver
Diffstat (limited to 'build-support')
-rw-r--r--build-support/python-bootstrap/PKGBUILD14
1 files changed, 12 insertions, 2 deletions
diff --git a/build-support/python-bootstrap/PKGBUILD b/build-support/python-bootstrap/PKGBUILD
index 240d043f..746cb43a 100644
--- a/build-support/python-bootstrap/PKGBUILD
+++ b/build-support/python-bootstrap/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer
pkgbase=python-bootstrap
-pkgname=(python-build python-installer python-tomli python-pep517 python-setuptools python-flit-core python-wheel python-typing_extensions python-packaging python-setuptools-scm python-jaraco.functools)
-pkgver=0.2
+pkgname=(python-build python-installer python-tomli python-pep517 python-setuptools python-flit-core python-wheel python-typing_extensions python-packaging python-setuptools-scm python-jaraco.functools python-calver)
+pkgver=0.3
pkgrel=1
arch=(any)
license=('custom')
@@ -23,6 +23,7 @@ source=(
"${pkgbase}-packaging::git+https://github.com/pypa/packaging.git"
"${pkgbase}-setuptools-scm::git+https://github.com/pypa/setuptools_scm.git"
"${pkgbase}-jaraco.functools::git+https://github.com/jaraco/jaraco.functools.git"
+ "${pkgbase}-calver::git+https://github.com/di/calver.git"
)
sha256sums=('SKIP'
'SKIP'
@@ -35,6 +36,7 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'SKIP')
prepare() {
@@ -52,6 +54,7 @@ prepare() {
git config submodule."external/packaging".url "${srcdir}/${pkgbase}"-packaging
git config submodule."external/setuptools_scm".url "${srcdir}/${pkgbase}"-setuptools-scm
git config submodule."external/jaraco.functools".url "${srcdir}/${pkgbase}"-jaraco.functools
+ git config submodule."external/calver".url "${srcdir}/${pkgbase}"-calver
git -c protocol.file.allow=always submodule update
git submodule update --init --recursive
@@ -139,3 +142,10 @@ package_python-jaraco.functools() {
cd python-bootstrap
python -m bootstrap.install dist/jaraco.functools-*-py3-none-any.whl -d $pkgdir
}
+
+package_python-calver() {
+ pkgdesc="Setuptools extension for CalVer package versions"
+ depends=(python)
+ cd python-bootstrap
+ python -m bootstrap.install dist/calver-*-py3-none-any.whl -d $pkgdir
+}