Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/build-support
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2023-04-29 12:43:22 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2023-04-29 12:43:22 +0200
commitbe13a1f801d48c4682556bb7708cb3e40aced104 (patch)
tree862ab51e652af1e732f37e04a71993619ce43b78 /build-support
parent71f99f307ec6869bffe5fd152cf5a47c8b5cf18b (diff)
fixed more in gcc11
Diffstat (limited to 'build-support')
-rw-r--r--build-support/gcc11/PKGBUILD10
-rw-r--r--build-support/gcc11/c8910
-rw-r--r--build-support/gcc11/c9910
3 files changed, 22 insertions, 8 deletions
diff --git a/build-support/gcc11/PKGBUILD b/build-support/gcc11/PKGBUILD
index 145c4ffa..85ad643a 100644
--- a/build-support/gcc11/PKGBUILD
+++ b/build-support/gcc11/PKGBUILD
@@ -17,7 +17,7 @@ _majorver=${pkgver%%.*}
_islver=0.24
pkgrel=6
pkgdesc='The GNU Compiler Collection (11.x.x)'
-arch=(x86_64)
+arch=(x86_64 pentium4 i686 i486)
license=(GPL LGPL FDL custom)
url='https://gcc.gnu.org'
makedepends=(
@@ -186,12 +186,7 @@ package_gcc11-libs() {
pkgdesc="Runtime libraries shipped by GCC (11.x.x)"
depends=('glibc>=2.27')
options=(!emptydirs !strip)
- provides=("${_pkgbase}-libs"
- "libgfortran.so"
- "libubsan.so"
- "libasan.so"
- "libtsan.so"
- "liblsan.so")
+ provides=("${_pkgbase}-libs" "libgfortran.so" "libubsan.so" "libasan.so" "liblsan.so")
cd gcc-build
make -C $CHOST/libgcc DESTDIR="$pkgdir" install-shared
@@ -335,7 +330,6 @@ eval "$(
sed '
s/\$pkgname-multilib//
s@libsanitizer/{a,l,ub,t}san@libsanitizer/{a,l,ub}san@
- /provides=/s/libtsan.so//
\@/usr/lib32/@ d
'
declare -f package_gcc11 | \
diff --git a/build-support/gcc11/c89 b/build-support/gcc11/c89
new file mode 100644
index 00000000..35486ea8
--- /dev/null
+++ b/build-support/gcc11/c89
@@ -0,0 +1,10 @@
+#!/bin/sh
+fl="-std=c89"
+for opt; do
+ case "$opt" in
+ -ansi|-std=c89|-std=iso9899:1990) fl="";;
+ -std=*) echo "`basename $0` called with non ANSI/ISO C option $opt" >&2
+ exit 1;;
+ esac
+done
+exec gcc $fl ${1+"$@"}
diff --git a/build-support/gcc11/c99 b/build-support/gcc11/c99
new file mode 100644
index 00000000..88dd8064
--- /dev/null
+++ b/build-support/gcc11/c99
@@ -0,0 +1,10 @@
+#!/bin/sh
+fl="-std=c99"
+for opt; do
+ case "$opt" in
+ -std=c99|-std=iso9899:1999) fl="";;
+ -std=*) echo "`basename $0` called with non ISO C99 option $opt" >&2
+ exit 1;;
+ esac
+done
+exec gcc $fl ${1+"$@"}