Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/build-support
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2023-05-11 10:02:07 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2023-05-11 10:02:07 +0200
commitbb6c50aab4613c47d8a93afa53c0c41ed30dc91b (patch)
tree3a8e997518c6602a33452d08b0958400ed6dca5f /build-support
parent535837ae47341345221e13cc454e25f345882ddb (diff)
added package-bootstrap from upstream to build-support
Diffstat (limited to 'build-support')
-rw-r--r--build-support/PKGBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/build-support/PKGBUILD b/build-support/PKGBUILD
new file mode 100644
index 00000000..f0d8b702
--- /dev/null
+++ b/build-support/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Angel Velasquez <angvp@archlinux.org>
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Eli Schwartz <eschwartz@archlinux.org>
+
+pkgname=python-bootstrap
+pkgver=3.11
+_commit=f11f8b16e28ef2e21c1f454d8925b2c512d32d37
+pkgrel=1
+pkgdesc="Python Bootstrap"
+arch=('any')
+license=('PSF')
+url="https://gitlab.archlinux.org/archlinux/python-bootstrap"
+depends=('python')
+makedepends=('git')
+provides=('python-build' 'python-flit' 'python-flit-core' 'python-installer''python-setuptools' 'python-wheel' 'python-tomli')
+source=("git+https://gitlab.archlinux.org/archlinux/python-bootstrap/#branch=$pkgver")
+sha512sums=('SKIP')
+
+export SETUPTOOLS_INSTALL_WINDOWS_SPECIFIC_FILES=0
+
+prepare() {
+ cd "${srcdir}/${pkgname}"
+ git submodule init; git submodule update
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ python -m bootstrap.build
+}
+
+wheels=(
+ build-0.9.0-py3-none-any.whl
+ flit_core-3.7.1-py3-none-any.whl
+ installer-0.5.1-py3-none-any.whl
+ pep517-0.13.0-py3-none-any.whl
+ setuptools-58.3.0.post20230511-py3-none-any.whl
+ tomli-2.0.1-py3-none-any.whl
+ wheel-0.37.0-py2.py3-none-any.whl
+)
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ for wheel in "${wheels[@]}"; do
+ python -m bootstrap.install --destdir="$pkgdir" "dist/$wheel"
+ done
+}