Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/build-support
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-10-08 14:45:29 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-10-08 14:45:29 +0200
commit4d7a8daf7e0df307afbb9abe9860d62a25a7f3d2 (patch)
treef577aca9dbf0c4ddc30cd71187dd8bd1f1769ebc /build-support
parent36afc61a4e6dd29042f09409b8a9382c45da2c86 (diff)
build-support/ruby-rake-compiler-bootstrap: fixes
Diffstat (limited to 'build-support')
-rw-r--r--build-support/ruby-rake-compiler-bootstrap/PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/build-support/ruby-rake-compiler-bootstrap/PKGBUILD b/build-support/ruby-rake-compiler-bootstrap/PKGBUILD
index af7a1e9e..0b69a084 100644
--- a/build-support/ruby-rake-compiler-bootstrap/PKGBUILD
+++ b/build-support/ruby-rake-compiler-bootstrap/PKGBUILD
@@ -43,12 +43,15 @@ package() {
# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
# and depend on 'ruby'
makedepends+=(ruby-bootstrap)
+depends=()
# install to bootstrap locatio /opt/ruby-xxx
eval "$(
declare -f package | \
sed '
- /_gemdir/ a mkdir -p "${pkgdir}"/opt/ruby-bootstrap-3.0.4/bin
+ /local _gemdir/ a mkdir -p "${pkgdir}"/opt/ruby-bootstrap-3.0.4/bin
+ /local _gemdir/ i export PATH="/opt/ruby-bootstrap-3.0.4/bin:${PATH}"
+ s|-n "${pkgdir}/usr/bin"|-n "$pkgdir/opt/ruby-bootstrap-3.0.4/bin"|
'
)"