Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/build-support
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-09-16 10:30:40 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-09-16 10:30:40 +0200
commit3761a66c7acf7455c87595704160489b98f42d57 (patch)
tree76f747bb3edbfd613d1545423498230da02d2766 /build-support
parent75118913f3834d2815cb7a2cf280bb07058727e8 (diff)
moved boost178-libs to community (must be public)
Diffstat (limited to 'build-support')
-rw-r--r--build-support/boost178-libs/PKGBUILD102
1 files changed, 0 insertions, 102 deletions
diff --git a/build-support/boost178-libs/PKGBUILD b/build-support/boost178-libs/PKGBUILD
deleted file mode 100644
index 4c27c20b..00000000
--- a/build-support/boost178-libs/PKGBUILD
+++ /dev/null
@@ -1,102 +0,0 @@
-# Maintainer: Evangelos Foutras <evangelos@foutrelis.com>
-# Contributor: Levente Polyak <anthraxx[at]archlinux[dot]org>
-# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
-# Contributor: Marius Knaust <marius.knaust@gmail.com>
-# Contributor: Ionut Biru <ibiru@archlinux.org>
-# Contributor: Stéphane Gaudreault <stephane@archlinux.org>
-# Contributor: kevin <kevin@archlinux.org>
-# Contributor: Giovanni Scafora <giovanni@archlinux.org>
-# Contributor: Kritoke <kritoke@gamebox.net>
-# Contributor: Luca Roccia <little_rock@users.sourceforge.net>
-
-pkgname=('boost178-libs')
-pkgver=1.78.0
-pkgrel=1
-_srcname=boost_${pkgver//./_}
-pkgdesc="Free peer-reviewed portable C++ source libraries"
-arch=(i486 i686 pentium4 'x86_64')
-url="https://www.boost.org/"
-license=('custom')
-makedepends=('icu' 'python' 'python-numpy' 'bzip2' 'zlib' 'openmpi' 'zstd')
-source=(https://boostorg.jfrog.io/artifactory/main/release/$pkgver/source/$_srcname.tar.gz
- $pkgname-locale-empty-vector.patch::https://github.com/boostorg/locale/commit/1ff0ead837b3.patch
- $pkgname-ublas-c++20-iterator.patch::https://github.com/boostorg/ublas/commit/a31e5cffa85f.patch)
-sha256sums=('94ced8b72956591c4775ae2207a9763d3600b30d9d7446562c552f0a14a63be7'
- '6c05bd362bc18908a7e23eec3b4a714f82c15c722bda4c340778e2f5b1a9bf25'
- 'aa38addb40d5f44b4a8472029b475e7e6aef1c460509eb7d8edf03491dc1b5ee')
-
-prepare() {
- cd $_srcname
-
- # https://github.com/boostorg/locale/issues/52
- patch -Np1 -d libs/locale <../$pkgname-locale-empty-vector.patch
-
- # https://github.com/boostorg/ublas/pull/97
- patch -Np2 -i ../$pkgname-ublas-c++20-iterator.patch
-}
-
-build() {
- local JOBS="$(sed 's/.*\(-j *[0-9]\+\).*/\1/' <<<$MAKEFLAGS)"
-
- pushd $_srcname/tools/build
- ./bootstrap.sh --cxxflags="$CXXFLAGS $LDFLAGS"
- ./b2 install --prefix="$srcdir"/fakeinstall
- ln -s b2 "$srcdir"/fakeinstall/bin/bjam
- popd
-
- cd $_srcname
- ./bootstrap.sh --with-toolset=gcc --with-icu --with-python=python3
-
- # support for OpenMPI
- echo "using mpi ;" >>project-config.jam
-
- # boostbook is needed by quickbook
- install -dm755 "$srcdir"/fakeinstall/share/boostbook
- cp -a tools/boostbook/{xsl,dtd} "$srcdir"/fakeinstall/share/boostbook/
-
- # install to $srcdir/fakeinstall in preparation for split packaging
- ./b2 install \
- variant=release \
- debug-symbols=off \
- threading=multi \
- runtime-link=shared \
- link=shared,static \
- toolset=gcc \
- python=3.10 \
- cflags="$CPPFLAGS $CFLAGS -fPIC -O3 -ffat-lto-objects" \
- cxxflags="$CPPFLAGS $CXXFLAGS -fPIC -O3 -ffat-lto-objects" \
- linkflags="$LDFLAGS" \
- --layout=system \
- $JOBS \
- \
- --prefix="$srcdir"/fakeinstall
-}
-
-package_boost178-libs() {
- pkgdesc+=' (runtime libraries)'
- depends=('bzip2' 'zlib' 'icu' 'zstd')
- optdepends=('openmpi: for mpi support')
-
- install -dm755 "$pkgdir"/usr/lib
- cp -a fakeinstall/lib/*.so* "$pkgdir"/usr/lib/
- # no develpment so links, just the so libs
- rm -f "$pkgdir"/usr/lib/*.so
-
- install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" $_srcname/LICENSE_1_0.txt
-}
-
-# vim:set ts=2 sw=2 et:
-# no LTO on i486
-if [ "$CARCH" = 'i486' ]; then
- sed -i '
- 1i options=(!lto)
- ' PKGBUILD
-fi
-if [ "$CARCH" == 'i486' ]; then
- eval "$(
- declare -f build | \
- sed '
- s/-ffat-lto-objects//g
- '
- )"
-fi