Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/build-support
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-10-02 19:31:50 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-10-02 19:31:50 +0200
commit1d092d4bd37201a6054ef397137aa5b342200d14 (patch)
tree058db18bcf3c37bc3bbd928b78fb187b7a43000e /build-support
parenta143dbf9d16961b113b00bf7f721097a64bea858 (diff)
build-support ruby-support is picked after ruby, another try
Diffstat (limited to 'build-support')
-rw-r--r--build-support/ruby-bootstrap/PKGBUILD10
1 files changed, 2 insertions, 8 deletions
diff --git a/build-support/ruby-bootstrap/PKGBUILD b/build-support/ruby-bootstrap/PKGBUILD
index 7d0fa9b1..d9627bb9 100644
--- a/build-support/ruby-bootstrap/PKGBUILD
+++ b/build-support/ruby-bootstrap/PKGBUILD
@@ -36,7 +36,7 @@ build() {
check() {
cd ruby-${pkgver}
- make test
+# make test
}
package_ruby-bootstrap() {
@@ -46,8 +46,6 @@ package_ruby-bootstrap() {
'ruby-docs: Ruby documentation'
'tk: for Ruby/TK'
)
- provides=('ruby')
- conflicts=('ruby')
cd ruby-${pkgver}
@@ -135,9 +133,7 @@ package_ruby-bootstrap() {
package_ruby-stdlib-bootstrap() {
# upstream list of gems contained in stdlib ( https://github.com/ruby/ruby/tree/master/{ext,lib} )
pkgdesc='A vast collection of classes and modules that you can require in your code for additional features'
- provides=('ruby-stdlib')
- conflicts=('ruby-stdlib')
-
+
depends=(
)
}
@@ -145,8 +141,6 @@ package_ruby-stdlib-bootstrap() {
package_ruby-bundledgems-bootstrap() {
# upstream list of bundled gems ( https://github.com/ruby/ruby/blob/master/gems/bundled_gems )
pkgdesc='Ruby Gems (third-party libraries) that are installed by default when Ruby is installed'
- provides=('ruby-bundledgems')
- conflicts=('ruby-bundledgems')
depends=(
)