Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/build-support
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2023-05-12 16:35:58 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2023-05-12 16:35:58 +0200
commit1a9038b24071546a11a5db104e43ce15de766831 (patch)
treea36c23878c71ae54ec15be3273c545d1d8dfb52b /build-support
parentbe986f0c0aa51c4c6defb09703cf7cecbfea8db9 (diff)
some cleanup
Diffstat (limited to 'build-support')
-rw-r--r--build-support/disabled/python-pip-bootstrap/PKGBUILD (renamed from build-support/python-pip-bootstrap/PKGBUILD)0
-rw-r--r--build-support/disabled/python-pip-bootstrap/install.sh (renamed from build-support/python-pip-bootstrap/install.sh)0
-rw-r--r--build-support/disabled/python-pip-bootstrap/install2.sh (renamed from build-support/python-pip-bootstrap/install2.sh)0
-rw-r--r--build-support/python-build-bootstrap/PKGBUILD33
4 files changed, 0 insertions, 33 deletions
diff --git a/build-support/python-pip-bootstrap/PKGBUILD b/build-support/disabled/python-pip-bootstrap/PKGBUILD
index 4afb97a8..4afb97a8 100644
--- a/build-support/python-pip-bootstrap/PKGBUILD
+++ b/build-support/disabled/python-pip-bootstrap/PKGBUILD
diff --git a/build-support/python-pip-bootstrap/install.sh b/build-support/disabled/python-pip-bootstrap/install.sh
index e81432e6..e81432e6 100644
--- a/build-support/python-pip-bootstrap/install.sh
+++ b/build-support/disabled/python-pip-bootstrap/install.sh
diff --git a/build-support/python-pip-bootstrap/install2.sh b/build-support/disabled/python-pip-bootstrap/install2.sh
index b6aa16fa..b6aa16fa 100644
--- a/build-support/python-pip-bootstrap/install2.sh
+++ b/build-support/disabled/python-pip-bootstrap/install2.sh
diff --git a/build-support/python-build-bootstrap/PKGBUILD b/build-support/python-build-bootstrap/PKGBUILD
deleted file mode 100644
index ec3630c4..00000000
--- a/build-support/python-build-bootstrap/PKGBUILD
+++ /dev/null
@@ -1,33 +0,0 @@
-# Maintainer: Filipe Laíns (FFY00) <lains@archlinux.org>
-# Maintainer: Daniel M. Capella <polyzen@archlinux.org>
-
-_pkgname=build
-pkgname=python-$_pkgname-bootstrap
-pkgver=0.10.0
-pkgrel=4
-pkgdesc='A simple, correct PEP 517 build frontend'
-arch=('any')
-url='https://github.com/pypa/build'
-license=('MIT')
-makedepends=('git' 'python-pip-bootstrap')
-checkdepends=('python-pytest' 'python-pytest-mock' 'python-pytest-rerunfailures' 'python-filelock' 'python-setuptools' 'python-toml' 'python-wheel')
-source=("git+$url#tag=$pkgver?signed")
-validpgpkeys=('3DCE51D60930EBA47858BA4146F633CBB0EB4BF2') # Filipe Laíns (FFY00) <lains@archlinux.org>
-sha512sums=('SKIP')
-
-build() {
- cd $_pkgname
-
- # we install build, installer with pip to break the cycle
- pip install build
- pip install installer
- pip install flit_core
-
- python -m build --wheel --skip-dependency-check --no-isolation
-}
-
-package() {
- cd $_pkgname
-
- python -m installer --destdir="$pkgdir" dist/*.whl
-}