Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/build-support
diff options
context:
space:
mode:
authorTasos Sahanidis <tasos@tasossah.com>2023-12-04 23:59:02 +0200
committerTasos Sahanidis <tasos@tasossah.com>2023-12-05 00:01:11 +0200
commit011fae64f764a20c2590d42da519e11f50b8f377 (patch)
treeec46f6b3c0d8613ff33012a4aa9ebd3659104b4a /build-support
parentffe6d36470ef77d4f4f55755718d31a2a9039f84 (diff)
build-support/python-bootstrap: Bootstrap more Python packages
Diffstat (limited to 'build-support')
-rw-r--r--build-support/python-bootstrap/PKGBUILD34
1 files changed, 32 insertions, 2 deletions
diff --git a/build-support/python-bootstrap/PKGBUILD b/build-support/python-bootstrap/PKGBUILD
index f9355e8b..d6afa242 100644
--- a/build-support/python-bootstrap/PKGBUILD
+++ b/build-support/python-bootstrap/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer
pkgbase=python-bootstrap
-pkgname=(python-build python-installer python-tomli python-pep517 python-setuptools python-flit-core python-wheel)
+pkgname=(python-build python-installer python-tomli python-pep517 python-setuptools python-flit-core python-wheel python-typing_extensions python-packaging python-setuptools-scm)
pkgver=0.1
pkgrel=1
arch=(pentium4 i686 i486)
@@ -11,7 +11,7 @@ url="https://gitlab.archlinux.org/archlinux/python-bootstrap"
# From archlinux-contrib
# package/parse-submodules https://github.com/jelly/python-bootstrap.git
source=(
- "${pkgbase}::git+https://github.com/jelly/python-bootstrap.git#branch=3.11"
+ "${pkgbase}::git+https://github.com/tatokis/python-bootstrap.git#branch=3.11"
"${pkgbase}-build::git+https://github.com/pypa/build.git"
"${pkgbase}-flit::git+https://github.com/takluyver/flit.git"
"${pkgbase}-installer::git+https://github.com/pypa/installer.git"
@@ -19,6 +19,9 @@ source=(
"${pkgbase}-setuptools::git+https://github.com/pypa/setuptools.git"
"${pkgbase}-tomli::git+https://github.com/hukkin/tomli.git"
"${pkgbase}-wheel::git+https://github.com/pypa/wheel.git"
+ "${pkgbase}-typing_extensions::git+https://github.com/python/typing_extensions.git"
+ "${pkgbase}-packaging::git+https://github.com/pypa/packaging.git"
+ "${pkgbase}-setuptools-scm::git+https://github.com/pypa/setuptools_scm.git"
)
sha256sums=('SKIP'
'SKIP'
@@ -27,6 +30,9 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
'SKIP')
prepare() {
@@ -40,6 +46,9 @@ prepare() {
git config submodule."external/setuptools".url "${srcdir}/${pkgbase}"-setuptools
git config submodule."external/tomli".url "${srcdir}/${pkgbase}"-tomli
git config submodule."external/wheel".url "${srcdir}/${pkgbase}"-wheel
+ git config submodule."external/typing_extensions".url "${srcdir}/${pkgbase}"-typing_extensions
+ git config submodule."external/packaging".url "${srcdir}/${pkgbase}"-packaging
+ git config submodule."external/setuptools_scm".url "${srcdir}/${pkgbase}"-setuptools-scm
git -c protocol.file.allow=always submodule update
git submodule update --init --recursive
@@ -100,3 +109,24 @@ package_python-wheel() {
python -m bootstrap.install dist/wheel-*-py2.py3-none-any.whl -d $pkgdir
}
+package_python-setuptools-scm() {
+ pkgdesc="Handles managing your python package versions in scm metadata"
+ depends=(python)
+ cd python-bootstrap
+ python -m bootstrap.install dist/setuptools_scm-*-py3-none-any.whl -d $pkgdir
+}
+
+package_python-typing_extensions() {
+ pkgdesc="Backported and Experimental Type Hints for Python 3.8+"
+ depends=(python)
+ cd python-bootstrap
+ python -m bootstrap.install dist/typing_extensions-*-py3-none-any.whl -d $pkgdir
+}
+
+package_python-packaging() {
+ pkgdesc="Core utilities for Python packages"
+ depends=(python)
+ cd python-bootstrap
+ python -m bootstrap.install dist/packaging-*-py3-none-any.whl -d $pkgdir
+}
+