Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/build-support/rust162
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-09-16 09:31:07 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-09-16 09:31:07 +0200
commit95becdb3dc32cd42af12850a9228e0f650dcca1d (patch)
tree464fa474cbaf79c4ce9c1422b6d0bbd364cc4fae /build-support/rust162
parent590c88fd77570b07956c28f6baaacb38d366d5c0 (diff)
disabled rust162 in build-support, rust is now 1.63
Diffstat (limited to 'build-support/rust162')
-rw-r--r--build-support/rust162/0001-bootstrap-Change-libexec-dir.patch22
-rw-r--r--build-support/rust162/0001-cargo-Change-libexec-dir.patch22
-rw-r--r--build-support/rust162/0002-compiler-Change-LLVM-targets.patch84
-rw-r--r--build-support/rust162/0003-compiler-Use-wasm-ld-for-wasm-targets.patch24
-rw-r--r--build-support/rust162/PKGBUILD303
-rw-r--r--build-support/rust162/config.toml.patch39
-rw-r--r--build-support/rust162/remove-include-linux-fs.h.patch59
7 files changed, 0 insertions, 553 deletions
diff --git a/build-support/rust162/0001-bootstrap-Change-libexec-dir.patch b/build-support/rust162/0001-bootstrap-Change-libexec-dir.patch
deleted file mode 100644
index 903a38dc..00000000
--- a/build-support/rust162/0001-bootstrap-Change-libexec-dir.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
-From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
-Date: Thu, 6 May 2021 20:14:58 +0200
-Subject: [PATCH] bootstrap: Change libexec dir
-
----
- src/bootstrap/dist.rs | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/bootstrap/dist.rs b/src/bootstrap/dist.rs
-index b1fae356d893..a9783708d7a7 100644
---- a/src/bootstrap/dist.rs
-+++ b/src/bootstrap/dist.rs
-@@ -950,7 +950,7 @@ fn run(self, builder: &Builder<'_>) -> Option<GeneratedTarball> {
- for dirent in fs::read_dir(cargo.parent().unwrap()).expect("read_dir") {
- let dirent = dirent.expect("read dir entry");
- if dirent.file_name().to_str().expect("utf8").starts_with("cargo-credential-") {
-- tarball.add_file(&dirent.path(), "libexec", 0o755);
-+ tarball.add_file(&dirent.path(), "lib", 0o755);
- }
- }
-
diff --git a/build-support/rust162/0001-cargo-Change-libexec-dir.patch b/build-support/rust162/0001-cargo-Change-libexec-dir.patch
deleted file mode 100644
index 06bc493d..00000000
--- a/build-support/rust162/0001-cargo-Change-libexec-dir.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
-From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
-Date: Thu, 6 May 2021 20:13:31 +0200
-Subject: [PATCH] cargo: Change libexec dir
-
----
- src/cargo/ops/registry/auth.rs | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/cargo/ops/registry/auth.rs b/src/cargo/ops/registry/auth.rs
-index 648e051e6dc2..a7b24e07e552 100644
---- a/src/cargo/ops/registry/auth.rs
-+++ b/src/cargo/ops/registry/auth.rs
-@@ -224,7 +224,7 @@ fn sysroot_credential(
- .parent()
- .and_then(|p| p.parent())
- .ok_or_else(|| format_err!("expected cargo path {}", cargo.display()))?;
-- let exe = root.join("libexec").join(format!(
-+ let exe = root.join("lib").join(format!(
- "cargo-credential-{}{}",
- cred_name,
- std::env::consts::EXE_SUFFIX
diff --git a/build-support/rust162/0002-compiler-Change-LLVM-targets.patch b/build-support/rust162/0002-compiler-Change-LLVM-targets.patch
deleted file mode 100644
index a6e58b9c..00000000
--- a/build-support/rust162/0002-compiler-Change-LLVM-targets.patch
+++ /dev/null
@@ -1,84 +0,0 @@
-From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
-From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
-Date: Fri, 12 Mar 2021 17:31:56 +0100
-Subject: [PATCH] compiler: Change LLVM targets
-
- - Change x86_64-unknown-linux-gnu to use x86_64-pc-linux-gnu
- - Change i686-unknown-linux-gnu to use i686-pc-linux-gnu
-
-Reintroduce the aliasing that was removed in 1.52.0 and alias the -pc-
-triples to the -unknown- triples. This avoids defining proper -pc-
-targets, as things break when this is done:
-
- - The crate ecosystem expects the -unknown- targets. Making -pc-
- rustc's host triple (and thus default target) would break various
- crates.
- - Firefox's build breaks when the host triple (from
- `rustc --version --verbose`) is different from the target triple
- (from `rustc --print target-list`) that best matches autoconf.
----
- compiler/rustc_session/src/config.rs | 2 +-
- compiler/rustc_target/src/spec/i686_unknown_linux_gnu.rs | 2 +-
- compiler/rustc_target/src/spec/mod.rs | 9 +++++++++
- .../rustc_target/src/spec/x86_64_unknown_linux_gnu.rs | 2 +-
- 4 files changed, 12 insertions(+), 3 deletions(-)
-
-diff --git a/compiler/rustc_session/src/config.rs b/compiler/rustc_session/src/config.rs
-index 14ad1a42a7d8..efd47c47293b 100644
---- a/compiler/rustc_session/src/config.rs
-+++ b/compiler/rustc_session/src/config.rs
-@@ -1867,7 +1867,7 @@ pub fn parse_target_triple(
- early_error(error_format, &format!("target file {path:?} does not exist"))
- })
- }
-- Some(target) => TargetTriple::TargetTriple(target),
-+ Some(target) => TargetTriple::from_alias(target),
- _ => TargetTriple::from_triple(host_triple()),
- }
- }
-diff --git a/compiler/rustc_target/src/spec/i686_unknown_linux_gnu.rs b/compiler/rustc_target/src/spec/i686_unknown_linux_gnu.rs
-index 0998c618f31a..91c79c7e4ff0 100644
---- a/compiler/rustc_target/src/spec/i686_unknown_linux_gnu.rs
-+++ b/compiler/rustc_target/src/spec/i686_unknown_linux_gnu.rs
-@@ -9,7 +9,7 @@ pub fn target() -> Target {
- base.stack_probes = StackProbeType::Call;
-
- Target {
-- llvm_target: "i686-unknown-linux-gnu".into(),
-+ llvm_target: "i686-pc-linux-gnu".into(),
- pointer_width: 32,
- data_layout: "e-m:e-p:32:32-p270:32:32-p271:32:32-p272:64:64-\
- f64:32:64-f80:32-n8:16:32-S128"
-diff --git a/compiler/rustc_target/src/spec/mod.rs b/compiler/rustc_target/src/spec/mod.rs
-index da0589cdd209..dc9865bdf64a 100644
---- a/compiler/rustc_target/src/spec/mod.rs
-+++ b/compiler/rustc_target/src/spec/mod.rs
-@@ -2506,6 +2506,15 @@ pub fn from_path(path: &Path) -> Result<Self, io::Error> {
- Ok(TargetTriple::TargetJson { path_for_rustdoc: canonicalized_path, triple, contents })
- }
-
-+ /// Creates a target triple from its alias
-+ pub fn from_alias(triple: String) -> Self {
-+ match triple.as_str() {
-+ "x86_64-pc-linux-gnu" => TargetTriple::from_triple("x86_64-unknown-linux-gnu"),
-+ "i686-pc-linux-gnu" => TargetTriple::from_triple("i686-unknown-linux-gnu"),
-+ _ => TargetTriple::TargetTriple(triple),
-+ }
-+ }
-+
- /// Returns a string triple for this target.
- ///
- /// If this target is a path, the file name (without extension) is returned.
-diff --git a/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs b/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs
-index e525cfdde14f..2dfe25f4f238 100644
---- a/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs
-+++ b/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs
-@@ -15,7 +15,7 @@ pub fn target() -> Target {
- | SanitizerSet::THREAD;
-
- Target {
-- llvm_target: "x86_64-unknown-linux-gnu".into(),
-+ llvm_target: "x86_64-pc-linux-gnu".into(),
- pointer_width: 64,
- data_layout: "e-m:e-p270:32:32-p271:32:32-p272:64:64-i64:64-f80:128-n8:16:32:64-S128"
- .into(),
diff --git a/build-support/rust162/0003-compiler-Use-wasm-ld-for-wasm-targets.patch b/build-support/rust162/0003-compiler-Use-wasm-ld-for-wasm-targets.patch
deleted file mode 100644
index c2002ae6..00000000
--- a/build-support/rust162/0003-compiler-Use-wasm-ld-for-wasm-targets.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
-From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
-Date: Sat, 6 Nov 2021 22:42:06 +0100
-Subject: [PATCH] compiler: Use wasm-ld for wasm targets
-
-We don't ship rust-lld.
----
- compiler/rustc_target/src/spec/wasm_base.rs | 3 +--
- 1 file changed, 1 insertion(+), 2 deletions(-)
-
-diff --git a/compiler/rustc_target/src/spec/wasm_base.rs b/compiler/rustc_target/src/spec/wasm_base.rs
-index de7b7374af31..9ea181ab8d8f 100644
---- a/compiler/rustc_target/src/spec/wasm_base.rs
-+++ b/compiler/rustc_target/src/spec/wasm_base.rs
-@@ -99,8 +99,7 @@ pub fn options() -> TargetOptions {
- // arguments just yet
- limit_rdylib_exports: false,
-
-- // we use the LLD shipped with the Rust toolchain by default
-- linker: Some("rust-lld".into()),
-+ linker: Some("wasm-ld".into()),
- lld_flavor: LldFlavor::Wasm,
- linker_is_gnu: false,
-
diff --git a/build-support/rust162/PKGBUILD b/build-support/rust162/PKGBUILD
deleted file mode 100644
index 33a068d3..00000000
--- a/build-support/rust162/PKGBUILD
+++ /dev/null
@@ -1,303 +0,0 @@
-# Maintainer: Johannes Löthberg <johannes@kyriasis.com>
-# Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
-# Contributor: Alexander F Rødseth <xyproto@archlinux.org>
-# Contributor: Daniel Micay <danielmicay@gmail.com>
-# Contributor: userwithuid <userwithuid@gmail.com>
-
-pkgbase=rust162
-pkgname=(rust162 rust162-musl rust162-wasm rust162-src)
-epoch=1
-pkgver=1.62.0
-pkgrel=1
-pkgdesc="Systems programming language focused on safety, speed and concurrency"
-url=https://www.rust-lang.org/
-arch=(i486 i686 pentium4 x86_64)
-license=(MIT Apache)
-options=(!emptydirs !strip !lto)
-depends=(gcc-libs llvm-libs curl libssh2 gcc)
-makedepends=(rust llvm libffi lib32-gcc-libs perl python cmake musl ninja
- wasi-libc lld)
-checkdepends=(procps-ng gdb)
-source=(
- "https://static.rust-lang.org/dist/rustc-$pkgver-src.tar.gz"{,.asc}
- 0001-cargo-Change-libexec-dir.patch
- 0001-bootstrap-Change-libexec-dir.patch
- 0002-compiler-Change-LLVM-targets.patch
- 0003-compiler-Use-wasm-ld-for-wasm-targets.patch
- remove-include-linux-fs.h.patch
-)
-sha256sums=('7d0878809b64d206825acae3eb7f60afb2212d81e3de1adf4c11c6032b36c027'
- 'SKIP'
- 'c901a9bb036c29ca092f7dbc8b447efdd9aa1044a902a88f9d024cb22681dc19'
- '7080a88e44234aa363ba6321f319c8d9621382dd9581748a43847dae005e55bd'
- '5137df0a3399e279db4c5b83ae8e99d2c1977f62aec2f90521edb02f51597064'
- '26bf232d144b81a303ed91f6a331ddf004c5d9fefd41a11e36b61812a34459aa'
- '34ed866e313e4580130a50118a4410d36fa0159123982521b6ef049439fc32ad')
-validpgpkeys=(108F66205EAEB0AAA8DD5E1C85AB96E6FA1BE5FE # Rust Language (Tag and Release Signing Key) <rust-key@rust-lang.org>
- 474E22316ABF4785A88C6E8EA2C794A986419D8A) # Tom Stellard <tstellar@redhat.com>
-
-prepare() {
- cd rustc-$pkgver-src
-
- # Patch bootstrap and cargo so credential helpers
- # are in /usr/lib instead of /usr/libexec
- patch -d src/tools/cargo -Np1 < ../0001-cargo-Change-libexec-dir.patch
- patch -Np1 -i ../0001-bootstrap-Change-libexec-dir.patch
-
- # Use our *-pc-linux-gnu targets, making LTO with clang simpler
- patch -Np1 -i ../0002-compiler-Change-LLVM-targets.patch
-
- # Use our wasm-ld
- patch -Np1 -i ../0003-compiler-Use-wasm-ld-for-wasm-targets.patch
-
- # https://github.com/llvm/llvm-project/issues/56421
- patch -Np1 -d src/llvm-project < ../remove-include-linux-fs.h.patch
-
- cat >config.toml <<END
-changelog-seen = 2
-profile = "user"
-
-[llvm]
-link-shared = true
-
-[build]
-target = [
- "x86_64-unknown-linux-gnu",
- "i686-unknown-linux-gnu",
- "x86_64-unknown-linux-musl",
- "wasm32-unknown-unknown",
- "wasm32-wasi",
-]
-cargo = "/usr/bin/cargo"
-rustc = "/usr/bin/rustc"
-rustfmt = "/usr/bin/rustfmt"
-locked-deps = true
-vendor = true
-tools = ["cargo", "rls", "clippy", "rustfmt", "analysis", "src", "rust-demangler"]
-sanitizers = true
-profiler = true
-
-# Generating docs fails with the wasm32-* targets
-docs = false
-
-[install]
-prefix = "/usr"
-
-[rust]
-debuginfo-level-std = 2
-channel = "stable"
-description = "Arch Linux $pkgbase $epoch:$pkgver-$pkgrel"
-rpath = false
-backtrace-on-ice = true
-remap-debuginfo = true
-jemalloc = true
-
-# LLVM crashes when passing an object through ThinLTO twice. This is triggered
-# when using rust code in cross-language LTO if libstd was built using ThinLTO.
-# http://blog.llvm.org/2019/09/closing-gap-cross-language-lto-between.html
-# https://github.com/rust-lang/rust/issues/54872
-codegen-units-std = 1
-
-# musl target produces warnings
-deny-warnings = false
-
-[dist]
-compression-formats = ["gz"]
-
-[target.x86_64-unknown-linux-gnu]
-llvm-config = "/usr/bin/llvm-config"
-
-[target.x86_64-unknown-linux-musl]
-sanitizers = false
-musl-root = "/usr/lib/musl"
-
-[target.wasm32-unknown-unknown]
-sanitizers = false
-profiler = false
-
-[target.wasm32-wasi]
-sanitizers = false
-profiler = false
-wasi-root = "/usr/share/wasi-sysroot"
-END
-}
-
-_pick() {
- local p="$1" f d; shift
- for f; do
- d="$srcdir/$p/$f"
- mkdir -p "$(dirname "$d")"
- mv "$f" "$d"
- rmdir -p --ignore-fail-on-non-empty "$(dirname "$f")"
- done
-}
-
-build() {
- cd rustc-$pkgver-src
-
- export RUST_BACKTRACE=1
-
- DESTDIR="$srcdir/dest-rust" python ./x.py install -j "$(nproc)"
-
- cd ../dest-rust
-
- # delete unnecessary files, e.g. files only used for the uninstall script
- rm usr/lib/rustlib/{components,install.log,rust-installer-version,uninstall.sh}
- rm usr/lib/rustlib/manifest-*
-
- # rustbuild always installs copies of the shared libraries to /usr/lib,
- # overwrite them with symlinks to the per-architecture versions
- mkdir -p usr/lib32
- ln -srft usr/lib usr/lib/rustlib/x86_64-unknown-linux-gnu/lib/*.so
- ln -srft usr/lib32 usr/lib/rustlib/i686-unknown-linux-gnu/lib/*.so
-
- mkdir -p usr/share/bash-completion
- mv etc/bash_completion.d usr/share/bash-completion/completions
-
- mkdir -p usr/share/licenses/rust
- mv -t usr/share/licenses/rust usr/share/doc/rust/{COPYRIGHT,LICENSE*}
-
- _pick dest-i686 usr/lib/rustlib/i686-unknown-linux-gnu usr/lib32
- _pick dest-musl usr/lib/rustlib/x86_64-unknown-linux-musl
- _pick dest-wasm usr/lib/rustlib/wasm32-*
- _pick dest-src usr/lib/rustlib/src
-}
-
-package_rust162() {
- optdepends=('lldb: rust-lldb script'
- 'gdb: rust-gdb script')
- provides=(cargo rustfmt)
- conflicts=(cargo rustfmt 'rust-docs<1:1.56.1-3')
- replaces=(cargo rustfmt cargo-tree 'rust-docs<1:1.56.1-3')
-
- cp -a dest-rust/* "$pkgdir"
-}
-
-package_lib32-rust-libs() {
- pkgdesc="32-bit target and libraries for Rust"
- depends=(rust lib32-gcc-libs)
- provides=(lib32-rust)
- conflicts=(lib32-rust)
- replaces=(lib32-rust)
-
- cp -a dest-i686/* "$pkgdir"
-
- mkdir -p "$pkgdir/usr/share/licenses"
- ln -s rust "$pkgdir/usr/share/licenses/$pkgname"
-}
-
-package_rust162-musl() {
- pkgdesc="Musl target for Rust"
- depends=(rust162)
-
- cp -a dest-musl/* "$pkgdir"
-
- mkdir -p "$pkgdir/usr/share/licenses"
- ln -s rust "$pkgdir/usr/share/licenses/$pkgname"
-}
-
-package_rust162-wasm() {
- pkgdesc="WebAssembly targets for Rust"
- depends=(rust162 lld)
-
- cp -a dest-wasm/* "$pkgdir"
-
- mkdir -p "$pkgdir/usr/share/licenses"
- ln -s rust "$pkgdir/usr/share/licenses/$pkgname"
-}
-
-package_rust162-src() {
- pkgdesc="Source code for the Rust standard library"
- depends=(rust162)
-
- cp -a dest-src/* "$pkgdir"
-
- mkdir -p "$pkgdir/usr/share/licenses"
- ln -s rust "$pkgdir/usr/share/licenses/$pkgname"
-}
-
-# vim:set ts=2 sw=2 et:
-# enable i686-unknown-linux-gnu target
-# and replace pentium4 (SSE2) with pentium3 (no SSE2) in the compiler spec file
-#
-# Also trying to reduce memory usage by building with
-# -debuginfo-level-std=1
-# see https://github.com/rust-lang/rust/issues/60294
-
-source+=(config.toml.patch)
-sha256sums+=('a8b42b5f47c0eaebafbb2cd1f39d2f944945cbb55e87d4dc21c7bd5b1b8964d8')
-
-eval "$(
- declare -f prepare | \
- sed '
- $ i patch -p1 -i "$srcdir/config.toml.patch"
- '
-)"
-
-# stop insanity of nproc (see FS#62952)
-#eval "$(
-# declare -f build | \
-# sed '
-# s/-j "$(nproc)"/-j1/
-# '
-#)"
-
-if [ "${CARCH}" != 'pentium4' ]; then
- eval "$(
- declare -f prepare | \
- sed '
- $ i sed -i "s/pentium4/pentium3/g" "$srcdir/rustc-$pkgver-src/compiler/rustc_target/src/spec/i686_unknown_linux_gnu.rs"
- '
- )"
-fi
-
-# Don't move lib32 support into rust32-lib, we are on 32-bit in the end
-# and don't draw a symlink to 64-bit libraries (but to 32-bit instead)
-# move rust-musl though, also patch architecture for musl accordingly
-eval "$(
- declare -f build | \
- sed '
- /mkdir.*usr\/lib32/d
- /ln.*x86_64.*/d
- /ln.*i686-unknown-linux-gnu.*/d
- /_pick.*dest-i686.*/d
- s/x86_64-unknown-linux-musl/i686-unknown-linux-musl/
- '
-)"
-
-eval "$(
- declare -f package_rust | \
- sed '
- /ln /s/x86_64-unknown-linux-gnu/i686-unknown-linux-gnu/g
- '
-)"
-
-eval "$(
- declare -f package_rust-musl | \
- sed '
- s/x86_64-unknown-linux-musl/i686-unknown-linux-musl/
- '
-)"
-
-# remove 32-bit stuff (shouldn't that be removed automatically?)
-pkgname=(
- $(
- printf '%s\n' "${pkgname[@]}" | \
- grep -v '^lib32-rust-libs'
- )
-)
-makedepends=(${makedepends[@]//lib32-gcc-libs/})
-
-# Enable on demand, if your previous rust is broken use previous version
-# from build-support (this is preferable to using rust-bin below, but
-# requires all intermediate versions of rust to be built
-#makedepends=(${makedepends[@]//rust/})
-#makedepends+=('rust148')
-
-# Enable on demand, if your previous rust is broken use previous version
-# from build-support
-#makedepends=(${makedepends[@]//rust/})
-#makedepends+=('rust159-bin')
-
-# rust 1.61 is built against llvm13.0, so force that in as a make dependency
-makedepends+=('llvm13-libs')
diff --git a/build-support/rust162/config.toml.patch b/build-support/rust162/config.toml.patch
deleted file mode 100644
index e262d277..00000000
--- a/build-support/rust162/config.toml.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-diff -rauN a/config.toml b/config.toml
---- a/config.toml 2021-12-09 10:47:47.487749605 +0100
-+++ b/config.toml 2021-12-09 11:12:50.904278715 +0100
-@@ -6,11 +6,10 @@
-
- [build]
- target = [
-- "x86_64-unknown-linux-gnu",
- "i686-unknown-linux-gnu",
-- "x86_64-unknown-linux-musl",
-+ "i686-unknown-linux-musl",
- "wasm32-unknown-unknown",
-- "wasm32-wasi",
-+ "wasm32-wasi"
- ]
- cargo = "/usr/bin/cargo"
- rustc = "/usr/bin/rustc"
-@@ -28,7 +27,7 @@
- prefix = "/usr"
-
- [rust]
--debuginfo-level-std = 2
-+debuginfo-level-std = 0
- channel = "stable"
- description = "Arch Linux $pkgbase $epoch:$pkgver-$pkgrel"
- rpath = false
-@@ -45,10 +44,10 @@
- [dist]
- compression-formats = ["gz"]
-
--[target.x86_64-unknown-linux-gnu]
-+[target.i686-unknown-linux-gnu]
- llvm-config = "/usr/bin/llvm-config"
-
--[target.x86_64-unknown-linux-musl]
-+[target.i686-unknown-linux-musl]
- sanitizers = false
- musl-root = "/usr/lib/musl"
-
diff --git a/build-support/rust162/remove-include-linux-fs.h.patch b/build-support/rust162/remove-include-linux-fs.h.patch
deleted file mode 100644
index bbf0d0e7..00000000
--- a/build-support/rust162/remove-include-linux-fs.h.patch
+++ /dev/null
@@ -1,59 +0,0 @@
-From 9cf13067cb5088626ba7ee1ec4c42ec59c7995a0 Mon Sep 17 00:00:00 2001
-From: Fangrui Song <i@maskray.me>
-Date: Mon, 11 Jul 2022 12:53:34 -0700
-Subject: [PATCH] [sanitizer] Remove #include <linux/fs.h> to resolve
- fsconfig_command/mount_attr conflict with glibc 2.36
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-It is generally not a good idea to mix usage of glibc headers and Linux UAPI
-headers (https://sourceware.org/glibc/wiki/Synchronizing_Headers). In glibc
-since 7eae6a91e9b1670330c9f15730082c91c0b1d570 (milestone: 2.36), sys/mount.h
-defines `fsconfig_command` which conflicts with linux/mount.h:
-
- .../usr/include/linux/mount.h:95:6: error: redeclaration of ‘enum fsconfig_command’
-
-Remove #include <linux/fs.h> which pulls in linux/mount.h. Expand its 4 macros manually.
-Android sys/mount.h doesn't define BLKBSZGET and it still needs linux/fs.h.
-In the long term we should move Linux specific definitions to sanitizer_platform_limits_linux.cpp
-but this commit is easy to cherry pick into older compiler-rt releases.
-
-Fix https://github.com/llvm/llvm-project/issues/56421
-
-Reviewed By: #sanitizers, vitalybuka, zatrazz
-
-Differential Revision: https://reviews.llvm.org/D129471
----
- .../sanitizer_platform_limits_posix.cpp | 10 ++++++----
- 1 file changed, 6 insertions(+), 4 deletions(-)
-
-diff --git a/compiler-rt/lib/sanitizer_common/sanitizer_platform_limits_posix.cpp b/compiler-rt/lib/sanitizer_common/sanitizer_platform_limits_posix.cpp
-index 4bd425435d56..3a94b260686f 100644
---- a/compiler-rt/lib/sanitizer_common/sanitizer_platform_limits_posix.cpp
-+++ b/compiler-rt/lib/sanitizer_common/sanitizer_platform_limits_posix.cpp
-@@ -73,7 +73,9 @@
- #include <sys/vt.h>
- #include <linux/cdrom.h>
- #include <linux/fd.h>
-+#if SANITIZER_ANDROID
- #include <linux/fs.h>
-+#endif
- #include <linux/hdreg.h>
- #include <linux/input.h>
- #include <linux/ioctl.h>
-@@ -876,10 +878,10 @@ unsigned struct_ElfW_Phdr_sz = sizeof(Elf_Phdr);
- unsigned IOCTL_EVIOCGPROP = IOCTL_NOT_PRESENT;
- unsigned IOCTL_EVIOCSKEYCODE_V2 = IOCTL_NOT_PRESENT;
- #endif
-- unsigned IOCTL_FS_IOC_GETFLAGS = FS_IOC_GETFLAGS;
-- unsigned IOCTL_FS_IOC_GETVERSION = FS_IOC_GETVERSION;
-- unsigned IOCTL_FS_IOC_SETFLAGS = FS_IOC_SETFLAGS;
-- unsigned IOCTL_FS_IOC_SETVERSION = FS_IOC_SETVERSION;
-+ unsigned IOCTL_FS_IOC_GETFLAGS = _IOR('f', 1, long);
-+ unsigned IOCTL_FS_IOC_GETVERSION = _IOR('v', 1, long);
-+ unsigned IOCTL_FS_IOC_SETFLAGS = _IOW('f', 2, long);
-+ unsigned IOCTL_FS_IOC_SETVERSION = _IOW('v', 2, long);
- unsigned IOCTL_GIO_CMAP = GIO_CMAP;
- unsigned IOCTL_GIO_FONT = GIO_FONT;
- unsigned IOCTL_GIO_UNIMAP = GIO_UNIMAP;