Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/build-support/python-six-nocheck
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2023-05-11 16:19:55 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2023-05-11 16:19:55 +0200
commit68a426c2e000489c6ba151ca9af6f0132a1358e3 (patch)
treee45c780636b2755186f7c48cdf78b6daa2c72ea5 /build-support/python-six-nocheck
parent1d4c7bf88bec357d5e9c4d21dabc46e51ec3617b (diff)
moved some old Python bootstrapping packages to disabled build-support
Diffstat (limited to 'build-support/python-six-nocheck')
-rw-r--r--build-support/python-six-nocheck/PKGBUILD32
1 files changed, 0 insertions, 32 deletions
diff --git a/build-support/python-six-nocheck/PKGBUILD b/build-support/python-six-nocheck/PKGBUILD
deleted file mode 100644
index 4709e2ae..00000000
--- a/build-support/python-six-nocheck/PKGBUILD
+++ /dev/null
@@ -1,32 +0,0 @@
-# Maintainer: Erich Eckner <deep42thought at archlinux32 dot org>
-# Contributor: Felix Yan <felixonmars@archlinux.org>
-# Contributor: Jelle van der Waa <jelle@vdwaa.nl>
-# Contributer: Allan McRae <allan@archlinux.org>
-
-# heavily borrowed from python-six's PKGBUILD
-
-pkgbase=python-six-nocheck
-pkgname=('python-six-nocheck')
-pkgver=1.15.0
-pkgrel=3
-pkgdesc="Python 2 and 3 compatibility utilities"
-arch=('any')
-url="https://pypi.python.org/pypi/six/"
-license=('MIT')
-makedepends=('python-setuptools')
-source=("https://pypi.io/packages/source/s/six/six-$pkgver.tar.gz")
-sha512sums=('eb840ac17f433f1fc4af56de75cfbfe0b54e6a737bb23c453bf09a4a13d768d153e46064880dc763f4c5cc2785b78ea6d3d3b4a41fed181cb9064837e3f699a9')
-
-build() {
- cp -a six-$pkgver{,-py2}
-}
-
-package_python-six-nocheck() {
- depends=('python')
- provides=("python-six=$pkgver")
- conflicts=('python-six')
-
- cd six-$pkgver
- python setup.py install --root "$pkgdir" --optimize=1
- install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
-}