Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/build-support/python-pip-bootstrap
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2023-05-12 20:02:25 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2023-05-12 20:02:25 +0200
commitbc0385f1158a2790ec155ddcaaaee81816a20a3d (patch)
tree229e9690c1636e85731e009b24bb400a731e1060 /build-support/python-pip-bootstrap
parentd934f0865d4e4c9477324294e082fb9c8961c4ca (diff)
moved python-pip-bootstrap from disabled (could be handy)
Diffstat (limited to 'build-support/python-pip-bootstrap')
-rw-r--r--build-support/python-pip-bootstrap/PKGBUILD18
-rw-r--r--build-support/python-pip-bootstrap/install.sh4
-rw-r--r--build-support/python-pip-bootstrap/install2.sh4
3 files changed, 26 insertions, 0 deletions
diff --git a/build-support/python-pip-bootstrap/PKGBUILD b/build-support/python-pip-bootstrap/PKGBUILD
new file mode 100644
index 00000000..4afb97a8
--- /dev/null
+++ b/build-support/python-pip-bootstrap/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Andreas Baumann <mail@andreasbaumann.cc>
+
+pkgname=('python-pip-bootstrap')
+pkgver=0.0.1
+pkgrel=2
+pkgdesc="bootstap pip and setuptools for bootstrapping python"
+arch=(i486 'i686' 'pentium4' 'x86_64' 'armv6h' 'armv7h')
+url="https://bootstrap.pypa.io/"
+source=("https://bootstrap.pypa.io/get-pip.py")
+sha512sums=('ba6c35de136e769bc67cbd41417c62ed2d7eebf893473ae3a98c50fd130b53fc02d7d9de266323197e30a4895c826c301a205595e129fb9e90d294d8f0e53afd')
+
+package_python-pip-bootstrap() {
+ depends=('python')
+ install=install.sh
+
+ mkdir -p "${pkgdir}/usr/bin"
+ cp "${srcdir}/get-pip.py" "${pkgdir}/usr/bin/."
+}
diff --git a/build-support/python-pip-bootstrap/install.sh b/build-support/python-pip-bootstrap/install.sh
new file mode 100644
index 00000000..e81432e6
--- /dev/null
+++ b/build-support/python-pip-bootstrap/install.sh
@@ -0,0 +1,4 @@
+post_install() {
+ echo "Bootstrapping python pip, setuptools and wheel.."
+ python /usr/bin/get-pip.py
+}
diff --git a/build-support/python-pip-bootstrap/install2.sh b/build-support/python-pip-bootstrap/install2.sh
new file mode 100644
index 00000000..b6aa16fa
--- /dev/null
+++ b/build-support/python-pip-bootstrap/install2.sh
@@ -0,0 +1,4 @@
+post_install() {
+ echo "Bootstrapping python2 pip, setuptools and wheel.."
+ python2 /usr/bin/get-pip2.py
+}