Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/build-support/python-bootstrap
diff options
context:
space:
mode:
authorTasos Sahanidis <tasos@tasossah.com>2024-01-06 03:41:44 +0200
committerTasos Sahanidis <tasos@tasossah.com>2024-01-06 03:41:44 +0200
commit71dd799c3a2a2ddd0941880627d94d0a3e417f91 (patch)
treee97cc524df5316e3ea7e7f3e6519cc9f3f1e7c9b /build-support/python-bootstrap
parentf7cde3df7662dc5af69f133453e299d35606554c (diff)
build-support/python-bootstrap: Fix dependencies for python-setuptools-scm
Diffstat (limited to 'build-support/python-bootstrap')
-rw-r--r--build-support/python-bootstrap/PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/build-support/python-bootstrap/PKGBUILD b/build-support/python-bootstrap/PKGBUILD
index be2e0854..91842b85 100644
--- a/build-support/python-bootstrap/PKGBUILD
+++ b/build-support/python-bootstrap/PKGBUILD
@@ -3,7 +3,7 @@
pkgbase=python-bootstrap
pkgname=(python-build python-installer python-tomli python-pep517 python-setuptools python-flit-core python-wheel python-typing_extensions python-packaging python-setuptools-scm)
pkgver=0.1
-pkgrel=2
+pkgrel=3
arch=(pentium4 i686 i486)
license=('custom')
makedepends=(python git)
@@ -111,7 +111,7 @@ package_python-wheel() {
package_python-setuptools-scm() {
pkgdesc="Handles managing your python package versions in scm metadata"
- depends=(python)
+ depends=(python python-packaging python-setuptools python-typing_extensions)
cd python-bootstrap
python -m bootstrap.install dist/setuptools_scm-*-py3-none-any.whl -d $pkgdir
}