Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/build-support/pacman-static/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2025-03-23 16:12:32 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2025-03-23 16:12:32 +0100
commit16b9979c9c27f7561fc0cd588eaf72785223c24d (patch)
tree3d962c26ae0ceda09f0dd528c5dfaec9aff079b8 /build-support/pacman-static/PKGBUILD
parent88c052a933c5c72be1dd29a2ba2c4315bd666387 (diff)
build-support/pacman-static: muon and de-pacmanification
Diffstat (limited to 'build-support/pacman-static/PKGBUILD')
-rw-r--r--build-support/pacman-static/PKGBUILD54
1 files changed, 6 insertions, 48 deletions
diff --git a/build-support/pacman-static/PKGBUILD b/build-support/pacman-static/PKGBUILD
index 9a2f0ca0..fab98f4b 100644
--- a/build-support/pacman-static/PKGBUILD
+++ b/build-support/pacman-static/PKGBUILD
@@ -354,52 +354,10 @@ package() {
"${pkgdir}"/usr/lib/pacman/lib/pkgconfig/*.pc \
"${pkgdir}"/usr/lib/pacman/bin/*
}
-# upstream git revision: 1a52f2e1d641587a1514c99b96d839368076288d
-
-depends+=(archlinux32-keyring)
-
-# fail if upstream changes makepkg.conf or pacman.conf
-for ((i=0; i<${#sha256sums[@]}; i++)); do
- # pacman.conf
- if [ "${sha256sums[${i}]}" = 'bc80e9d0439caddd29b99a69b5060b5589cad2398c23abc5b2b8b990fae6ad8c' ]; then
- sha256sums[${i}]='3e482ca4e98386679cec02b51e32c6a13caf3dee365a850567547f616a69408f'
- fi
- # makepkg.conf
- if [ "${sha256sums[${i}]}" = 'd99c1f9608362fff9ab3a2ca0a3096a317927b42a6725bc86599da6849c9c67c' ]; then
- sha256sums[${i}]='82e963060a02c9a04cf5296bb4c5e732d3c3d0666d221ddaf2b3367989b9d894'
- fi
- # rust.conf (for now keep the upstream one)
-done
-
-if [ ! "${CARCH}" = "i686" ]; then
- # patch architecture where needed
- eval "$(
- declare -f package | \
- sed '
- /install.*makepkg.conf/ a \
- sed -i "s@i686@'"${CARCH}"'@g; /^CHOST/ s/pentium4-/i686-/" "$pkgdir/etc/makepkg.conf"
- '
- )"
-fi
# patch pacman for automatic architecture detection (applied in wildcard patch above)
source+=('replace-i686-by-pentium4-when-architecture-is-auto.patch')
-sha256sums+=('6a7906bd28a57cbcff58d856ffefbbb9096a163aaff79913b4fac69d75d0028a')
-
-# not supported on i486 -fcf-protection
-# LTO currently no available on i486
-if [ "${CARCH}" = "i486" ]; then
- eval "$(
- {
- declare -f package || \
- printf 'package() {\n}\n'
- } \
- | sed '
- $i sed -i "s/-fcf-protection//g" "$pkgdir/etc/makepkg.conf"
- $i sed -i "s/LTOFLAGS.*/LTOFLAGS=\\\"-fno-lto\\\"/" "$pkgdir/etc/makepkg.conf"
- '
- )"
-fi
+sha512sums+=('c1a23b64f7d27ee70724415e8aa274494ceff441f5f1547f2f7ce365f1d8416b95b85275653531f259381bdef0fdd903e22f961a10c3ebaea8d0965bdaa06508')
# If this still applies, it only does for i486:
# (while not having Python, it's not working on any CARCH)
@@ -427,10 +385,10 @@ fi
# use muon instead of meson, no python (and meson needs python)
makedepends=(${makedepends[@]//meson/})
-makedepends+=(muon-meson)
+makedepends+=(muon-meson ninja)
source+=(pacman-trailing-slash-muon.patch)
-sha256sums+=(f295ff9967d38117bb5a29237716abb997197c69d8d2eeb449db49b85582be02)
+sha512sums+=(2a657849a5b8879abf731ffd6ee1eb2b69502e03444010dc0e398427a40e86aa4383fcff7bd6d08abd67386b7945c093f56c64202f9867fd5dfb65c5bc6d0b3f)
eval "$(
declare -f build | \
@@ -448,11 +406,11 @@ eval "$(
'
declare -f package | \
sed '
- /meson install/ i \
+ /ninja install/ i \
cd $srcdir/pacman/build
- /meson install/ a \
+ /ninja install/ a \
cd ..
- s/DESTDIR="$pkgdir" meson install -C build/muon install -d "$pkgdir"/
+ s/.*ninja install.*/muon install -d "$pkgdir"/
'
)"