Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/build-support/disabled
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2023-05-11 16:19:55 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2023-05-11 16:19:55 +0200
commit68a426c2e000489c6ba151ca9af6f0132a1358e3 (patch)
treee45c780636b2755186f7c48cdf78b6daa2c72ea5 /build-support/disabled
parent1d4c7bf88bec357d5e9c4d21dabc46e51ec3617b (diff)
moved some old Python bootstrapping packages to disabled build-support
Diffstat (limited to 'build-support/disabled')
-rw-r--r--build-support/disabled/python-packaging-bootstrap/PKGBUILD44
-rw-r--r--build-support/disabled/python-setuptools-bootstrap/PKGBUILD62
-rw-r--r--build-support/disabled/python-six-nocheck/PKGBUILD32
3 files changed, 138 insertions, 0 deletions
diff --git a/build-support/disabled/python-packaging-bootstrap/PKGBUILD b/build-support/disabled/python-packaging-bootstrap/PKGBUILD
new file mode 100644
index 00000000..db4de3a4
--- /dev/null
+++ b/build-support/disabled/python-packaging-bootstrap/PKGBUILD
@@ -0,0 +1,44 @@
+# upstream git revision: a6efc98e6cda125be25a45410c45f87a8769ca76
+
+# Maintainer: Erich Eckner <deep42thought at archlinux32 dot org>
+# Contributor: Felix Yan <felixonmars@archlinux.org>
+
+# heavily borrowed from python-packagings PKGBUILD
+
+pkgbase=python-packaging-bootstrap
+_pkgbase="${pkgbase%-*}"
+pkgname=(python-packaging-bootstrap python2-packaging-bootstrap)
+pkgver='20.9'
+pkgrel='1'
+pkgdesc="Core utilities for Python packages - bootstrap version"
+arch=('any')
+url="https://github.com/pypa/packaging"
+license=('Apache')
+makedepends=('python-dephell' 'python-setuptools' 'python2-setuptools' 'python-pyparsing'
+ 'python2-pyparsing')
+source=("https://github.com/pypa/packaging/archive/$pkgver/$_pkgbase-$pkgver.tar.gz")
+sha512sums=('fb71f1036cfaacbe94fdee663af31d6ad1960f73ecc95cba87b461c2d7d2ea90085853bb4682b146492d8c48f784b60ef082e3b1259269857166b143cd9a920b')
+
+build() {
+ cd packaging-$pkgver
+ python setup.py build
+ python2 setup.py build
+}
+
+package_python-packaging-bootstrap() {
+ depends=('python-pyparsing' 'python-six')
+ provides=("python-packaging=$pkgver")
+ conflicts=('python-packaging')
+
+ cd packaging-$pkgver
+ python setup.py install --root "$pkgdir"
+}
+
+package_python2-packaging-bootstrap() {
+ depends=('python2-pyparsing' 'python2-six')
+ provides=("python2-packaging=$pkgver")
+ conflicts=('python2-packaging')
+
+ cd packaging-$pkgver
+ python2 setup.py install --root "$pkgdir"
+}
diff --git a/build-support/disabled/python-setuptools-bootstrap/PKGBUILD b/build-support/disabled/python-setuptools-bootstrap/PKGBUILD
new file mode 100644
index 00000000..8b46c9e3
--- /dev/null
+++ b/build-support/disabled/python-setuptools-bootstrap/PKGBUILD
@@ -0,0 +1,62 @@
+# upstream git revision: a6efc98e6cda125be25a45410c45f87a8769ca76
+
+# Maintainer: Erich Eckner <arch32 at eckner dot net>
+# Contributor: Angel Velasquez <angvp@archlinux.org>
+# Contributor: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Eli Schwartz <eschwartz@archlinux.org>
+
+# heavily borrowed from python-setuptools' PKGBUILD
+
+pkgname=python-setuptools-bootstrap
+_pkgname="${pkgname%-*}"
+pkgver='56.2.0'
+pkgrel='2'
+epoch='1'
+pkgdesc="Easily download, build, install, upgrade, and uninstall Python packages - bootstrap variant"
+arch=('any')
+license=('PSF')
+url="https://pypi.org/project/setuptools/"
+makedepends=('python' 'git')
+source=("$_pkgname-$pkgver.tar.gz::https://github.com/pypa/setuptools/archive/v$pkgver.tar.gz")
+sha512sums=('ff062db8adf4478bb55650e0c5ef162aed1e4de2b6dba8c0b6ea986b669ef2c8af126247f281feb749cd8a54c0bd9af54e99289073ab742b0d4e26a0208b963c')
+
+export SETUPTOOLS_INSTALL_WINDOWS_SPECIFIC_FILES=0
+
+prepare() {
+
+ # Remove post-release tag since we are using stable tags
+ sed -e '/tag_build = .post/d' \
+ -e '/tag_date = 1/d' \
+ -i setuptools-$pkgver/setup.cfg
+
+ # 'Clean' installation is expected to fail since we removed bundled packages
+ sed -i '/^def test_clean_env_install/i import pytest\n\n@pytest.mark.xfail' setuptools-$pkgver/setuptools/tests/test_virtualenv.py
+
+ # Tests failed. Importing an unbundled new setuptools in a virtualenv does not work, but this won't
+ # affect normal virtualenv usage (which don't have to import the unbundled setuptools in *current*
+ # dir.
+ sed -e '/^def test_pip_upgrade_from_source/i @pytest.mark.xfail' \
+ -e '/^def test_test_command_install_requirements/i @pytest.mark.xfail' \
+ -e '/^def test_no_missing_dependencies/i @pytest.mark.xfail' \
+ -i setuptools-$pkgver/setuptools/tests/test_virtualenv.py
+
+ cd "$srcdir"/setuptools-$pkgver
+ sed -i -e "s|^#\!.*/usr/bin/env python|#!/usr/bin/env python3|" setuptools/command/easy_install.py
+}
+
+build() {
+ cd "$srcdir"/setuptools-$pkgver
+ python bootstrap.py
+ python setup.py build
+}
+
+package() {
+ depends=("${_deps[@]/#/python-}")
+ provides=('python-distribute' "python-setuptools=${pkgver}")
+ replaces=('python-distribute')
+
+ cd "$srcdir"/setuptools-$pkgver
+ # create directory before installing (otherwise installing fails)
+ mkdir build/scripts-3.10
+ python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1 --skip-build
+}
diff --git a/build-support/disabled/python-six-nocheck/PKGBUILD b/build-support/disabled/python-six-nocheck/PKGBUILD
new file mode 100644
index 00000000..4709e2ae
--- /dev/null
+++ b/build-support/disabled/python-six-nocheck/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Erich Eckner <deep42thought at archlinux32 dot org>
+# Contributor: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Jelle van der Waa <jelle@vdwaa.nl>
+# Contributer: Allan McRae <allan@archlinux.org>
+
+# heavily borrowed from python-six's PKGBUILD
+
+pkgbase=python-six-nocheck
+pkgname=('python-six-nocheck')
+pkgver=1.15.0
+pkgrel=3
+pkgdesc="Python 2 and 3 compatibility utilities"
+arch=('any')
+url="https://pypi.python.org/pypi/six/"
+license=('MIT')
+makedepends=('python-setuptools')
+source=("https://pypi.io/packages/source/s/six/six-$pkgver.tar.gz")
+sha512sums=('eb840ac17f433f1fc4af56de75cfbfe0b54e6a737bb23c453bf09a4a13d768d153e46064880dc763f4c5cc2785b78ea6d3d3b4a41fed181cb9064837e3f699a9')
+
+build() {
+ cp -a six-$pkgver{,-py2}
+}
+
+package_python-six-nocheck() {
+ depends=('python')
+ provides=("python-six=$pkgver")
+ conflicts=('python-six')
+
+ cd six-$pkgver
+ python setup.py install --root "$pkgdir" --optimize=1
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}