Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/build-support/disabled/ant19
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2025-03-16 20:12:42 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2025-03-16 20:12:42 +0100
commitb79b42e58b90a54eb5644ae10d04b5bfde26fb75 (patch)
treeefc264b13e87d1fccab33b445d86c9ed7147bc61 /build-support/disabled/ant19
parentfc72f1b90bda328df3f4531ca2814a1205f92396 (diff)
moved build-support/disabled to build-support-disabled (collides with some pkginfo stuff otherwise)
Diffstat (limited to 'build-support/disabled/ant19')
-rw-r--r--build-support/disabled/ant19/PKGBUILD102
-rw-r--r--build-support/disabled/ant19/ant.conf8
-rw-r--r--build-support/disabled/ant19/apache-ant-1.9.15-https-and-repo-urls.patch73
3 files changed, 0 insertions, 183 deletions
diff --git a/build-support/disabled/ant19/PKGBUILD b/build-support/disabled/ant19/PKGBUILD
deleted file mode 100644
index 4f829a3b..00000000
--- a/build-support/disabled/ant19/PKGBUILD
+++ /dev/null
@@ -1,102 +0,0 @@
-# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
-# Maintainer: Guillaume ALAUX <guillaume@archlinux.org>
-# Contributor: Andrew Wright <andreww@photism.org>
-# Contributor: Paul Mattal <paul@archlinux.org>
-
-pkgbase=ant19
-_pkgbase=ant
-pkgname=('ant19' 'ant19-doc')
-pkgver=1.9.15
-pkgrel=3
-pkgdesc='Java based build tool'
-url='https://ant.apache.org/'
-arch=('any')
-license=('APACHE')
-makedepends=('bash' 'bin32-jdk7' 'junit' 'java-hamcrest')
-source=(https://www.apache.org/dist/ant/source/apache-${_pkgbase}-${pkgver}-src.tar.bz2{,.asc}
- ant.conf
- apache-ant-1.9.15-https-and-repo-urls.patch
- NetRexx.zip::ftp://ftp.software.ibm.com/software/awdtools/netrexx/NetRexx.zip)
-
-sha256sums=('7f7251009dc53e60afac47d0df6bd7e7d3cdba9fa7fec67b7a95412e8becdc8b'
- 'SKIP'
- '23bbef577b56d48adb1985dbd9795e5533146646f1e8bb879dd061a4014ffcf2'
- 'fc8ed0be9586293a8a7f6cf8d245d1db56c43598b6a155ee27f7a4eeb59cafec'
- '1f99f054e9b1e412d29823088f3fa7cfce90a7af25d907a60a6d7908a6b97ea4')
-validpgpkeys=(
- 'CE8075A251547BEE249BC151A2115AE15F6B8B72' # Stefan Bodewig
- '8DA70C00DF7AF1B0D2F9DC74DDBCC1270A29D081' # jaikiran@apache <jaikiran@apache.org>
-)
-
-_replace_lib() {
- # explicitly call rm to ensure we replace instead of add
- rm "$2"
- ln -s "$1" "$2"
-}
-
-prepare() {
- cd apache-${_pkgbase}-${pkgver}
- patch -Np1 < $srcdir/apache-ant-1.9.15-https-and-repo-urls.patch
- mkdir -p ~/.ant/tempcache
- cp $srcdir/NetRexx.zip ~/.ant/tempcache/.
- sed -i 's|/usr/bin/python|/usr/bin/python2|' src/script/runant.py
-}
-
-build() {
- cd apache-${_pkgbase}-${pkgver}
- export JAVA_HOME=/usr/lib/jvm/java-7-jdk
- ./bootstrap.sh
- bootstrap/bin/ant -Ddest=optional -f fetch.xml
- _replace_lib /usr/share/java/junit.jar lib/optional/junit-4.12.jar
- _replace_lib /usr/share/java/hamcrest-core.jar lib/optional/hamcrest-core-1.3.jar
- _replace_lib /usr/share/java/hamcrest-library.jar lib/optional/hamcrest-library-1.3.jar
- bootstrap/bin/ant dist
-}
-
-package_ant19() {
- depends=('bin32-jdk7' 'bash')
- optdepends=('junit: junit tasks'
- 'java-hamcrest: junit tasks')
- conflicts=('ant')
- backup=('etc/ant.conf')
-
- cd apache-${_pkgbase}-${pkgver}/apache-${_pkgbase}-${pkgver}
- local _ant_home=/usr/share/ant
-
- install -d "${pkgdir}${_ant_home}"
- cp -Rp etc "${pkgdir}${_ant_home}"
-
- find bin -type f -a ! -name \*.bat -a ! -name \*.cmd \
- -exec install -Dm 755 {} -t "${pkgdir}${_ant_home}/bin" \;
- install -d "${pkgdir}/usr/bin"
- ln -s /usr/share/ant/bin/ant "${pkgdir}/usr/bin/ant"
-
- install -Dm 644 "${srcdir}/ant.conf" -t "${pkgdir}/etc"
- install -Dm 644 lib/*.jar -t "${pkgdir}/usr/share/java/ant"
- ln -s /usr/share/java/ant "${pkgdir}${_ant_home}/lib"
-
- install -Dm 644 ../{LICENSE,NOTICE} -t "${pkgdir}/usr/share/licenses/${pkgname}"
-}
-
-package_ant19-doc() {
- pkgdesc='Apache Ant build tool documentation'
- conflicts=('ant-doc')
-
- install -d "${pkgdir}/usr/share/doc/ant"
- cp -r apache-${_pkgbase}-${pkgver}/apache-${_pkgbase}-${pkgver}/manual/* \
- "${pkgdir}/usr/share/doc/ant"
-}
-
-# vim: ts=2 sw=2 et:
-
-# i486-specific
-if [ "${CARCH}" = "i486" ]; then
- _JARCH=i386
- _DOC_ARCH=x86
-fi
-
-# pentium4-specific
-if [ "${CARCH}" = "pentium4" ]; then
- _JARCH=i386
- _DOC_ARCH=x86
-fi
diff --git a/build-support/disabled/ant19/ant.conf b/build-support/disabled/ant19/ant.conf
deleted file mode 100644
index 63bf219a..00000000
--- a/build-support/disabled/ant19/ant.conf
+++ /dev/null
@@ -1,8 +0,0 @@
-# Apache Ant start script configuration file
-ANT_HOME=/usr/share/ant
-
-# Optional jars and their dependencies
-OPT_JAR_LIST=/usr/share/java/junit.jar:/usr/share/java/hamcrest-core.jar
-LOCALCLASSPATH=${OPT_JAR_LIST}
-
-# vim:ft=sh
diff --git a/build-support/disabled/ant19/apache-ant-1.9.15-https-and-repo-urls.patch b/build-support/disabled/ant19/apache-ant-1.9.15-https-and-repo-urls.patch
deleted file mode 100644
index 605b4f7b..00000000
--- a/build-support/disabled/ant19/apache-ant-1.9.15-https-and-repo-urls.patch
+++ /dev/null
@@ -1,73 +0,0 @@
-diff -rauN apache-ant-1.9.15/fetch.xml apache-ant-1.9.15-https-and-repo-urls-patch/fetch.xml
---- apache-ant-1.9.15/fetch.xml 2020-05-10 15:42:29.000000000 +0200
-+++ apache-ant-1.9.15-https-and-repo-urls-patch/fetch.xml 2021-05-14 20:17:38.020978197 +0200
-@@ -329,19 +329,19 @@
- <f2 project="tomcat" archive="jasper-runtime"/>
- <f2 project="javax.servlet" archive="servlet-api"/>
- </target>
--
-+<!--
- <target name="jai"
- description="load Java Advanced Imaging"
- depends="init">
- <f2 project="javax.media" archive="jai-core" id="jboss"
-- repository="https://repository.jboss.org/nexus/content/groups/public/"/>
-+ repository="http://mvnrepository.com/"/>
- <f2 project="com.sun.media" archive="jai-codec" id="jboss"
-- repository="https://repository.jboss.org/nexus/content/groups/public/"/>
-+ repository="http://repository.jboss.org/nexus/content/groups/public/"/>
- </target>
--
-+-->
- <target name="netrexx"
- description="load NetRexx compiler"
-- depends="init-no-m2,-setup-temp-cache,-fetch-netrexx,-fetch-netrexx-no-commons-net">
-+ depends="init-no-m2,-setup-temp-cache">
- <checksum file="${temp.dir}/NetRexx.zip" algorithm="SHA-256" property="${netrexx.sha256}" verifyProperty="netrexx.hash.matches"/>
- <fail message="NetRexx.zip fetched via ftp has an unexpected SHA-256 checksum, the file may have been tampered with">
- <condition>
-@@ -361,18 +361,22 @@
-
- <available property="have.commons.net" classname="org.apache.commons.net.ftp.FTPClientConfig"/>
-
-+<!--
- <target name="-fetch-netrexx" if="have.commons.net">
- <get-ftp-file host="ftp.software.ibm.com" remotedir="/software/awdtools/netrexx"
- filename="NetRexx.zip" localdir="${temp.dir}"/>
- </target>
-+-->
-
-+<!--
- <target name="-fetch-netrexx-no-commons-net" unless="have.commons.net">
- <get src="ftp://ftp.software.ibm.com/software/awdtools/netrexx/NetRexx.zip"
- dest="${temp.dir}/NetRexx.zip" skipexisting="true"/>
- </target>
-+-->
-
- <target name="all"
- description="load all the libraries (except jython)"
-- depends="antunit,ivy,logging,junit,xml,networking,regexp,antlr,bcel,jdepend,bsf,debugging,script,javamail,jspc,jai,netrexx"/>
-+ depends="antunit,ivy,logging,junit,xml,networking,regexp,antlr,bcel,jdepend,bsf,debugging,script,javamail,jspc,netrexx"/>
-
- </project>
-diff -rauN apache-ant-1.9.15/lib/libraries.properties apache-ant-1.9.15-https-and-repo-urls-patch/lib/libraries.properties
---- apache-ant-1.9.15/lib/libraries.properties 2020-05-10 15:42:29.000000000 +0200
-+++ apache-ant-1.9.15-https-and-repo-urls-patch/lib/libraries.properties 2021-05-14 20:06:47.150502384 +0200
-@@ -17,7 +17,7 @@
-
- # If you change this, change the checksum to match
- m2.version=2.1.3
--m2.url=https://archive.apache.org/dist/maven/ant-tasks
-+m2.url=http://archive.apache.org/dist/maven/ant-tasks
- m2.artifact-name=maven-ant-tasks
- m2.jar.name=${m2.artifact-name}-${m2.version}.jar
- #this is the URL of the antlib library, that is pulled down for everything else.
-@@ -26,7 +26,7 @@
- m2.sha1.checksum=b09be554228d66d208e5fef5266844aacf443abc
-
- # Repository to use by default for fetching dependencies.
--m2.repo=https://repo1.maven.org/maven2/
-+m2.repo=http://insecure.repo1.maven.org/maven2/
-
- # hashes of libraries loaded over insecure connections
- netrexx.sha256=1f99f054e9b1e412d29823088f3fa7cfce90a7af25d907a60a6d7908a6b97ea4