Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/build-support-disabled/ffmpeg
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2025-03-16 20:12:42 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2025-03-16 20:12:42 +0100
commitb79b42e58b90a54eb5644ae10d04b5bfde26fb75 (patch)
treeefc264b13e87d1fccab33b445d86c9ed7147bc61 /build-support-disabled/ffmpeg
parentfc72f1b90bda328df3f4531ca2814a1205f92396 (diff)
moved build-support/disabled to build-support-disabled (collides with some pkginfo stuff otherwise)
Diffstat (limited to 'build-support-disabled/ffmpeg')
-rw-r--r--build-support-disabled/ffmpeg/PKGBUILD13
1 files changed, 13 insertions, 0 deletions
diff --git a/build-support-disabled/ffmpeg/PKGBUILD b/build-support-disabled/ffmpeg/PKGBUILD
new file mode 100644
index 00000000..9dbe9953
--- /dev/null
+++ b/build-support-disabled/ffmpeg/PKGBUILD
@@ -0,0 +1,13 @@
+# disable x264/xs265/dav1d to break cycles
+depends=(${depends[@]//libx264.so/})
+depends=(${depends[@]//libx265.so/})
+depends=(${depends[@]//libdav1d.so/})
+
+eval "$(
+ declare -f build | \
+ sed '
+ s/--enable-libx264/--disable-libx264/
+ s/--enable-libx265/--disable-libx265/
+ s/--enable-libdav1d/--disable-libdav1d/
+ '
+)"