Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTasos Sahanidis <tasos@tasossah.com>2024-03-21 19:40:10 +0200
committerTasos Sahanidis <tasos@tasossah.com>2024-03-21 19:40:10 +0200
commitf31ae7c54ff29bb63b767a5781a6fefcac491734 (patch)
tree9b02de08d8ba832bf4a08ad15cb76d87c0c404ea
parentef68af9c11b756bfd2a3c4fdb28cab95547e638e (diff)
extra/opencolorio: Fix SSE patching
-rw-r--r--extra/opencolorio/OpenColorIO-2.1.1-no-sse2.patch12
-rw-r--r--extra/opencolorio/PKGBUILD14
2 files changed, 2 insertions, 24 deletions
diff --git a/extra/opencolorio/OpenColorIO-2.1.1-no-sse2.patch b/extra/opencolorio/OpenColorIO-2.1.1-no-sse2.patch
deleted file mode 100644
index f6ad78c1..00000000
--- a/extra/opencolorio/OpenColorIO-2.1.1-no-sse2.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -rauN OpenColorIO-2.1.1/share/cmake/utils/CompilerFlags.cmake OpenColorIO-2.1.1-no-sse2-patch/share/cmake/utils/CompilerFlags.cmake
---- OpenColorIO-2.1.1/share/cmake/utils/CompilerFlags.cmake 2021-12-16 20:19:03.000000000 +0100
-+++ OpenColorIO-2.1.1-no-sse2-patch/share/cmake/utils/CompilerFlags.cmake 2022-04-02 11:24:18.450648391 +0200
-@@ -86,7 +86,7 @@
- ###############################################################################
- # Define if SSE2 can be used.
-
--include(CheckSupportSSE2)
-+#include(CheckSupportSSE2)
-
- if(NOT HAVE_SSE2)
- message(STATUS "Disabling SSE optimizations, as the target doesn't support them")
diff --git a/extra/opencolorio/PKGBUILD b/extra/opencolorio/PKGBUILD
index 7d8f94cf..2bed32b2 100644
--- a/extra/opencolorio/PKGBUILD
+++ b/extra/opencolorio/PKGBUILD
@@ -1,16 +1,6 @@
-# Disable SSE2 in the cmake probing (we cannot set it from outside, so
-# cross-compilation or building in a chrooted environment fails)
-source+=('OpenColorIO-2.1.1-no-sse2.patch')
-sha512sums+=('8055b90d387e2cd674a25344b520d093ef8f761f294a77c71694f7ba93806a58350140b7e373e91432d555def5addd35fad4aca59518aab12b56c5b6106c4352')
+# Disable SSE2
if [ "$CARCH" = 'i686' -o "$CARCH" = 'i486' ]; then
eval "$(
- {
- declare -f prepare || \
- printf 'prepare() {\n}\n'
- } \
- | sed '
- $i cd "$srcdir/OpenColorIO-$pkgver" \
- patch -Np1 -i "$srcdir/OpenColorIO-2.1.1-no-sse2.patch"
- '
+ declare -f build | sed 's/cmake /cmake -DOCIO_USE_SIMD=OFF /'
)"
fi