Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-05-01 10:18:41 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-05-01 10:18:41 +0200
commitf14bc42870577dcf2b2910cfd37dfaa514606457 (patch)
tree46c6a991e624290e528333512bf408d139ef9a7b
parentb4ae155a87cc7ff7ffe0ec13477cee513dcb7a5a (diff)
extra/js91: applying patches from js78
-rw-r--r--extra/js91/PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/extra/js91/PKGBUILD b/extra/js91/PKGBUILD
new file mode 100644
index 00000000..34e6b72d
--- /dev/null
+++ b/extra/js91/PKGBUILD
@@ -0,0 +1,26 @@
+# target adaption (no clue how this ever worked before!?)
+eval "$(
+ declare -f build | \
+ sed '
+ s/x86_64-unknown-linux-gnu/i686-unknown-linux-gnu/g
+ '
+)"
+
+# see FS32#138, ignoring failing test for now
+unset check
+
+# no simd optimization on non-pentium4
+if [ "$CARCH" = 'i486' -o "$CARCH" = 'i686' ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s/--enable-rust-simd/--disable-rust-simd/g
+ '
+ )"
+fi
+
+# hard pinning rust version (as it fails with rust 1.50)
+# this rust version now needs llvm11
+makedepends=(${makedepends[@]//rust/})
+makedepends_i686+=(rust148 llvm11)
+makedepends_pentium4+=(rust148 llvm11)