Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2023-04-07 18:17:34 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2023-04-07 18:17:34 +0200
commitee19a1895403d52a28409aa6a3045a130dcea40e (patch)
tree99bec1a780606e8606020fde42ef6569b14fb762
parentcf6a3c28e1a8b6ea166012a9b333b02a720eef2a (diff)
extra/js102: redone fmathlib patch for doubles
-rw-r--r--extra/js102/PKGBUILD15
-rw-r--r--extra/js102/firefox-102.9.0-fdlibm.patch15
2 files changed, 30 insertions, 0 deletions
diff --git a/extra/js102/PKGBUILD b/extra/js102/PKGBUILD
index 00dd2d2d..9e2f792c 100644
--- a/extra/js102/PKGBUILD
+++ b/extra/js102/PKGBUILD
@@ -6,6 +6,21 @@ eval "$(
'
)"
+# 214:49.30 /build/firefox/src/firefox-99.0.1/modules/fdlibm/src/math_private.h:34:21: error: conflicting
+# declaration ?typedef __double_t double_t?
+# and
+# typedef __float_t float_t;
+# /usr/include/math.h:169:21: note: previous declaration as ?typedef long double float_t?
+# typedef long double float_t;
+source+=('firefox-102.9.0-fdlibm.patch')
+sha256sums+=('6fc1e1b2d95a9334fc132e47f66fc6832eefd8750d600480f92cccfff2c0e936')
+eval "$(
+ declare -f prepare | \
+ sed '
+ $ i patch -p1 -i "$srcdir/firefox-102.9.0-fdlibm.patch"
+ '
+)"
+
# see FS32#138, ignoring failing test for now
unset check
diff --git a/extra/js102/firefox-102.9.0-fdlibm.patch b/extra/js102/firefox-102.9.0-fdlibm.patch
new file mode 100644
index 00000000..7748f857
--- /dev/null
+++ b/extra/js102/firefox-102.9.0-fdlibm.patch
@@ -0,0 +1,15 @@
+diff -rauN firefox-102.9.0/modules/fdlibm/src/math_private.h firefox-102.9.0-fdlibm-patch/modules/fdlibm/src/math_private.h
+--- firefox-102.9.0/modules/fdlibm/src/math_private.h 2023-03-10 00:59:37.000000000 +0100
++++ firefox-102.9.0-fdlibm-patch/modules/fdlibm/src/math_private.h 2023-04-07 18:08:57.774736387 +0200
+@@ -30,7 +30,11 @@
+ * Adapted from https://github.com/freebsd/freebsd-src/search?q=__double_t
+ */
+
++#if defined __FLT_EVAL_METHOD__ && (__FLT_EVAL_METHOD__ == 2)
++typedef long double __double_t;
++#else
+ typedef double __double_t;
++#endif
+ typedef __double_t double_t;
+
+ /*