Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTasos Sahanidis <tasos@tasossah.com>2024-04-25 08:04:45 +0300
committerTasos Sahanidis <tasos@tasossah.com>2024-04-25 08:04:45 +0300
commite7c5e2a0fdb85ec7acd647293140139f4e262e27 (patch)
tree1f7cc8966bdd7348ce494a693d7b4dd2a4517e7e
parent8e8f498fb4a2b2569f9e94170df03ef30b8ca600 (diff)
extra/ruby: Add hack to find gems
-rw-r--r--extra/ruby/PKGBUILD3
1 files changed, 3 insertions, 0 deletions
diff --git a/extra/ruby/PKGBUILD b/extra/ruby/PKGBUILD
index 2ee10842..b03abc17 100644
--- a/extra/ruby/PKGBUILD
+++ b/extra/ruby/PKGBUILD
@@ -1,3 +1,6 @@
+# Hack
+eval "$(declare -f build | sed 's@./configure@./configure --with-search-path=/usr/lib/ruby/${pkgver:0:3}.0/x86-linux@')"
+
# patch architecture in helper shared libs
if [ "${CARCH}" = "pentium4" -o "${CARCH}" = "i686" ]; then
eval "$(