Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2023-03-05 11:01:29 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2023-03-05 11:01:29 +0100
commitdc01853850a556477dbdede416136733ace9bd01 (patch)
tree280275ba227249d33c81d674e9ad2b2350994448
parent7b4b545d762a65781aca6c90172dfb28a70db727 (diff)
extra/clisp: disabled LTO on all platforms, added 4-byte alignment patch from voidlinux
-rw-r--r--extra/clisp/PKGBUILD18
1 files changed, 18 insertions, 0 deletions
diff --git a/extra/clisp/PKGBUILD b/extra/clisp/PKGBUILD
new file mode 100644
index 00000000..16aecfee
--- /dev/null
+++ b/extra/clisp/PKGBUILD
@@ -0,0 +1,18 @@
+# no LTO
+sed -i "
+ /^options=/ a options+=('!lto')
+" PKGBUILD
+eval "$(
+ declare -f build | \
+ sed '
+ s/-ffat-lto-objects//
+ '
+)"
+
+# alignment of function (from VoidLinux)
+eval "$(
+ declare -f build | \
+ sed '
+ s|./configure|CFLAGS+=" -falign-functions=4" ./configure|
+ '
+)"