Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTasos Sahanidis <tasos@tasossah.com>2024-04-08 13:24:56 +0300
committerTasos Sahanidis <tasos@tasossah.com>2024-04-08 13:24:56 +0300
commitb43ded72a692ff76968fe6be1d93a495924a7e67 (patch)
treeaaf2ba7936b4d76c265990ec389529bc48a0bb74
parent1c399f16620aade606ed769b68da528ce7ba01ff (diff)
core/glib2: Clean up patch
-rw-r--r--core/glib2/PKGBUILD51
1 files changed, 6 insertions, 45 deletions
diff --git a/core/glib2/PKGBUILD b/core/glib2/PKGBUILD
index fd577a7e..2d6cf671 100644
--- a/core/glib2/PKGBUILD
+++ b/core/glib2/PKGBUILD
@@ -1,47 +1,8 @@
-# https://gitlab.gnome.org/GNOME/glib/issues/1626
-# gvariant is not properly aligned:
-# GLib:ERROR:../glib/glib/gvariant-serialiser.c:174:g_variant_serialised_check:
-# assertion failed (alignment & (gsize) serialised.data == 0): (3 == 0)
-# 23/256 glib:glib+slow / gvariant test fails
-# there is a fix for 2.60, but will not backport to 2.58.2
+# The timer test is still flaky, so ignore the tests for now
+# https://gitlab.gnome.org/GNOME/glib/-/issues/820#note_2076472
eval "$(
- declare -f check | \
- sed '
- s/meson test -C build/meson test -C build || true/
- '
-)"
-
-# i486-specific
-if [ "${CARCH}" = "i486" ]; then
- # all but one test succeed, for now disable testing
- # ERROR: timer - too few tests run (expected 7, got 0)
- # ERROR: timer - exited with status 134 (terminated by signal 6?)
- eval "$(
- declare -f check | \
- sed '
- s/\(meson test.*\)/\1 || true/
- '
- )"
-fi
-
-# remove usr/lib/installed-tests only if it exists
-eval "$(
- declare -f package_glib2 | \
- sed '
- s@rm -r "$pkgdir/usr/lib/installed-tests@test -d "$pkgdir/usr/lib/installed-tests" \&\& rm -r "$pkgdir/usr/lib/installed-tests@
- '
-)"
-
-# installing gtkdoc fails currently with not being able to find
-# glib-object.h, no clue why. Dropping building the documentation
-# for now
-eval "$(
- declare -f build | \
- sed '
- s/-D gtk_doc=true/-D gtk_doc=false/
- '
- declare -f package_glib2 | \
- sed '
- /mv.*gtk-doc/d
- '
+declare -f check | \
+ sed '
+ s/\(meson test.*\)/\1 || true/
+ '
)"