Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2023-07-07 10:24:26 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2023-07-07 10:24:26 +0200
commit8fd23797888a9b7e9d13230b442e606f28ec2f95 (patch)
tree4d132223b7d0d16f23b9cc0ff4f683bcc5475dbc
parent548ed2eda98a9f42bbc913f78665609537d4180f (diff)
extra/python-build: new trial to bootstrap
-rw-r--r--extra/python-build/PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/extra/python-build/PKGBUILD b/extra/python-build/PKGBUILD
new file mode 100644
index 00000000..8bc03356
--- /dev/null
+++ b/extra/python-build/PKGBUILD
@@ -0,0 +1,19 @@
+# boostrapping python modules
+
+# no testing no test or optional dependencies
+unset check
+unset checkdepends
+unset optdepends
+
+# no documentation, breaking the cycle with python-spinx
+makedepends=(${makedepends[@]//python-sphinx*/})
+eval "$(
+ declare -f build | \
+ sed '
+ /sphinx-build/d
+ '
+ declare -f package | \
+ sed '
+ /docs\/build\/html/d
+ '
+)"