Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTasos Sahanidis <tasos@tasossah.com>2024-04-09 20:40:29 +0300
committerTasos Sahanidis <tasos@tasossah.com>2024-04-09 20:47:32 +0300
commit8e2ff131d2e3c84c58315238e803e633a3260942 (patch)
treed7b739e52baab974fe0efb0844d375e04e77662a
parentbd8e70fc33077aeaa3c7822e6adc2b7374876ae1 (diff)
extra/protobuf: Clean up patching
-rw-r--r--extra/protobuf/PKGBUILD27
1 files changed, 2 insertions, 25 deletions
diff --git a/extra/protobuf/PKGBUILD b/extra/protobuf/PKGBUILD
index ba06c136..ca6fdb6b 100644
--- a/extra/protobuf/PKGBUILD
+++ b/extra/protobuf/PKGBUILD
@@ -1,33 +1,10 @@
-source+=('https://github.com/protocolbuffers/protobuf/commit/c94b66706bec17d918495f4715183a5eaf0f8044.patch'
- 'fix_static_assert_fail_on_32bit.patch'
-)
-
-sha512sums+=('SKIP'
- 'c124cdab5cfb45274d6cfc45d1eb3bb4d6a6e9128a4b84ca0c3b6dd5ddbfa69bb3cf168dc2a5f51ffdd9125246e5e134e22943e56ccdda78a4a0b90eb6ccd164'
-)
-
-_prepare() {
- patch -d $pkgbase-$pkgver -p1 < fix_static_assert_fail_on_32bit.patch # Fix 32 bit builds
- patch -d $pkgbase-$pkgver -p1 < c94b66706bec17d918495f4715183a5eaf0f8044.patch # Fix some 32 bit tests
-}
-
-eval "$(
- {
- declare -f prepare || \
- echo 'prepare()'
- } | \
- sed '$ i _prepare'
-)"
-
# ignore failing tests
eval "$(
declare -f check | \
sed '
- s@cmake --build build --target check@cmake --build build --target check || true@
- s@python setup.py test@python setup.py test || true@
+ s@\(ctest .*\);@\1 || true;@
'
-)
-"
+)"
# no LTO on i486
if [ "$CARCH" = 'i486' ]; then