Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2020-07-07 10:24:52 +0200
committerErich Eckner <git@eckner.net>2020-07-07 10:24:52 +0200
commit815f4f2a13fceba73ad20b180d1822245e0051e4 (patch)
tree23349b3d0bd6835b723f77319f81d61b79f7e006
parent778248161eb17b45efcdc93b15ead8ed24052add (diff)
community/fpc: the PP-compiler is located under the *old* pkgver, not the new one
-rw-r--r--community/fpc/PKGBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/community/fpc/PKGBUILD b/community/fpc/PKGBUILD
index 4e121deb..e73fc0e3 100644
--- a/community/fpc/PKGBUILD
+++ b/community/fpc/PKGBUILD
@@ -5,6 +5,13 @@
# a ppc386 symlink in build (PP variable) because the Makefile is trying to
# guess the target platform by executing fpc
+_pkgver=$(
+ find /usr/lib/fpc -name ppc386 \
+ | cut -d/ -f5 \
+ | sort -V \
+ | tail -n1
+)
+
eval "$(
declare -f package | \
sed '
@@ -17,10 +24,10 @@ eval "$(
p
s@i486@pentium4@
}
- s@NOGDB=1@NOGDB=1 PP=/usr/lib/fpc/$pkgver/ppc386 @
+ s@NOGDB=1@NOGDB=1 PP=/usr/lib/fpc/$_pkgver/ppc386 @
'
declare -f build | \
sed '
- s@NOGDB=1@NOGDB=1 PP=/usr/lib/fpc/$pkgver/ppc386 @
+ s@NOGDB=1@NOGDB=1 PP=/usr/lib/fpc/$_pkgver/ppc386 @
'
)"