Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTasos Sahanidis <tasos@tasossah.com>2024-04-08 01:29:51 +0300
committerTasos Sahanidis <tasos@tasossah.com>2024-04-08 01:29:51 +0300
commit7874533eba8a1a6e84a83dfee598062ad138cc46 (patch)
tree7190a1f7e2f97e4a90ba6f3b254e7dcd342ccdf0
parent3e67fcd36ff7153ee7dd48cec2d00f57d1acaec3 (diff)
extra/go: Rebase patch and disable go17 bootstrap
-rw-r--r--extra/go/PKGBUILD6
-rw-r--r--extra/go/go-x87.patch13
2 files changed, 7 insertions, 12 deletions
diff --git a/extra/go/PKGBUILD b/extra/go/PKGBUILD
index c4adc372..a9fa58bd 100644
--- a/extra/go/PKGBUILD
+++ b/extra/go/PKGBUILD
@@ -33,7 +33,7 @@ fi
# https://go-review.googlesource.com/c/go/+/257963
source+=('go-x87.patch')
-sha256sums+=('8b124eaa7521bd0e3760b514829b1ecce3d3cd169f99c3629ff50b7769303802')
+sha256sums+=('10e036bb7b9c468485a4ea878343918160b914a51aad67ad75839c85bd492b54')
eval "$(
{
declare -f prepare || \
@@ -46,7 +46,3 @@ eval "$(
# tests are failing, ignore them
unset check
-
-# bootstrap via go17
-makedepends=(${makedepends[@]//go/})
-makedepends+=('go17')
diff --git a/extra/go/go-x87.patch b/extra/go/go-x87.patch
index 0c0a584b..96da987c 100644
--- a/extra/go/go-x87.patch
+++ b/extra/go/go-x87.patch
@@ -1,15 +1,14 @@
-diff -rauN go/src/buildall.bash go-x87-patch/src/buildall.bash
---- go/src/buildall.bash 2023-04-04 17:38:07.330008547 +0200
-+++ go-x87-patch/src/buildall.bash 2023-04-04 17:39:07.929938685 +0200
-@@ -37,6 +37,7 @@
-
+--- go/src/buildall.bash 2024-03-29 15:27:02.000000000 +0000
++++ buildall.bash 2024-04-07 22:22:43.457800687 +0000
+@@ -42,6 +42,7 @@
gettargets() {
- ../bin/go tool dist list | sed -e 's|/|-|'
+ ../bin/go tool dist list | sed -e 's|/|-|' |
+ egrep -v '^(android|ios)' # need C toolchain even for cross-compiling
+ echo linux-386-387
echo linux-arm-arm5
}
-@@ -63,11 +64,15 @@
+@@ -68,11 +69,15 @@
echo "### Building $target"
export GOOS=$(echo $target | sed 's/-.*//')
export GOARCH=$(echo $target | sed 's/.*-//')