Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-10-06 16:00:40 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-10-06 16:00:40 +0200
commit5dcc3243fb645fd13f8b2d6db4bb2381adbf4040 (patch)
tree8adde38c5eb6bd40ea437deff10fd66b0a04c8fe
parentc38f6fa9a74e713cf193fa5a42ac79f21ba82014 (diff)
community/ruby-rake-compiler: bootstrapping
-rw-r--r--community/ruby-rake-compiler/PKGBUILD14
1 files changed, 14 insertions, 0 deletions
diff --git a/community/ruby-rake-compiler/PKGBUILD b/community/ruby-rake-compiler/PKGBUILD
new file mode 100644
index 00000000..1cd5ffb6
--- /dev/null
+++ b/community/ruby-rake-compiler/PKGBUILD
@@ -0,0 +1,14 @@
+# bootstrapping with ruby-bootstrap in /opt/ruby-xxx
+depends=(ruby-bootstrap)
+
+# no documentation during bootstrapping
+makedepends=(${makedepends[@]//ruby-rdoc/})
+
+# install to final destination in /usr and not into /opt/ruby-xxx
+eval "$(
+ declare -f package | \
+ sed '
+ s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
+ '
+)"
+