Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2025-03-20 10:18:40 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2025-03-20 10:18:40 +0100
commit46574cf0e24be803b0fd164a5a46ec8b6230f3ec (patch)
treee71b6c346f88e29adcf1f892525e31a23b863348
parent8a673d1b41ee2e9cc13c3b970c23e59191370267 (diff)
core/pacman: removed some rust stuff from makepkg.conf (lives in rust.conf now?)
-rw-r--r--core/pacman/PKGBUILD8
-rw-r--r--core/pacman/makepkg.conf2
-rw-r--r--core/pacman/pacman.conf1
3 files changed, 7 insertions, 4 deletions
diff --git a/core/pacman/PKGBUILD b/core/pacman/PKGBUILD
index 2efb1da1..8b799985 100644
--- a/core/pacman/PKGBUILD
+++ b/core/pacman/PKGBUILD
@@ -6,11 +6,11 @@ depends+=(archlinux32-keyring)
for ((i=0; i<${#sha256sums[@]}; i++)); do
# pacman.conf
if [ "${sha256sums[${i}]}" = 'bc80e9d0439caddd29b99a69b5060b5589cad2398c23abc5b2b8b990fae6ad8c' ]; then
- sha256sums[${i}]='3e482ca4e98386679cec02b51e32c6a13caf3dee365a850567547f616a69408f'
+ sha256sums[${i}]='394dd60f0033e65f1ccfac4f70450a5957516ab1467add723e65a8a4c7891b9d'
fi
# makepkg.conf
if [ "${sha256sums[${i}]}" = 'd99c1f9608362fff9ab3a2ca0a3096a317927b42a6725bc86599da6849c9c67c' ]; then
- sha256sums[${i}]='82e963060a02c9a04cf5296bb4c5e732d3c3d0666d221ddaf2b3367989b9d894'
+ sha256sums[${i}]='c63a4902c4d2f0928c0cd68ee5dedec08b1b372b6d90c71d7cfe0384b681559e'
fi
# rust.conf (for now keep the upstream one)
done
@@ -100,3 +100,7 @@ eval "$(
# fails happilly at the moment, going full risk now and installing it anyway..
unset check
unset checkdepends
+
+# overwrite wrong checksum on rust.conf
+sha256sums[5]='6fe03e6ea3f69d99d59a48847a8ae97c2160fca847c7aedf7b89d05e4aa9386d'
+
diff --git a/core/pacman/makepkg.conf b/core/pacman/makepkg.conf
index 69c05355..e44bcf8e 100644
--- a/core/pacman/makepkg.conf
+++ b/core/pacman/makepkg.conf
@@ -48,13 +48,11 @@ CXXFLAGS="$CFLAGS -Wp,-D_GLIBCXX_ASSERTIONS"
LDFLAGS="-Wl,-O1 -Wl,--sort-common -Wl,--as-needed -Wl,-z,relro -Wl,-z,now \
-Wl,-z,pack-relative-relocs"
LTOFLAGS="-flto=auto"
-RUSTFLAGS="-Cforce-frame-pointers=yes"
#-- Make Flags: change this for DistCC/SMP systems
#MAKEFLAGS="-j2"
#-- Debugging flags
DEBUG_CFLAGS="-g"
DEBUG_CXXFLAGS="$DEBUG_CFLAGS"
-DEBUG_RUSTFLAGS="-C debuginfo=2"
#########################################################################
# BUILD ENVIRONMENT
diff --git a/core/pacman/pacman.conf b/core/pacman/pacman.conf
index 780c9a87..37fe7443 100644
--- a/core/pacman/pacman.conf
+++ b/core/pacman/pacman.conf
@@ -15,6 +15,7 @@
#LogFile = /var/log/pacman.log
#GPGDir = /etc/pacman.d/gnupg/
#HookDir = /etc/pacman.d/hooks/
+HookDir = /usr/share/libalpm/hooks/
HoldPkg = pacman glibc
#XferCommand = /usr/bin/curl -L -C - -f -o %o %u
#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u