Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2025-03-14 09:37:01 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2025-03-14 09:37:01 +0100
commit451aafbc22bdf3c7ff611b9ab3a507186ecb6c38 (patch)
tree7c23f616f4d8c448af414a50e8fb9e6624396173
parentbf85fe9b1a9c348c6728cb56311a51b969749227 (diff)
core/libxml2: trying to build with shared library and muon (in a binary chroot)
-rw-r--r--core/libxml2/PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/core/libxml2/PKGBUILD b/core/libxml2/PKGBUILD
index c405a7f3..9538d277 100644
--- a/core/libxml2/PKGBUILD
+++ b/core/libxml2/PKGBUILD
@@ -2,15 +2,16 @@ makedepends+=(git)
# use muon instead of meson, no python (and meson needs python)
makedepends=(${makedepends[@]//meson/})
-makedepends+=(muon-meson)
+#makedepends+=(muon-meson)
eval "$(
declare -f build | \
sed '
s/python=true/python=false/
+ s/legacy=true/legacy=false/
/arch-meson/ i \
cd $srcdir/libxml2
- s/arch-meson.*/arch-muon ${meson_options[@]} ./
+ s/arch-meson.*/arch-muon -D minimum=true -D default_library=both ${meson_options[@]} ./
s/meson compile -C build/muon samu -v -j1/
'
declare -f check | \