Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTasos Sahanidis <tasos@tasossah.com>2024-05-12 06:52:14 +0300
committerTasos Sahanidis <tasos@tasossah.com>2024-05-12 06:52:14 +0300
commit1f6ab22ec8d2efe37c9ff908539f893d7c6f1af2 (patch)
tree0ea9360778e4f6c21198ef3494d8c4ee7d7cbc5d
parentf09ae0f2ffc0485dd6c8e40eb76211611bd8a949 (diff)
extra/python-pendulum: Third attempt
-rw-r--r--extra/python-pendulum/PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/extra/python-pendulum/PKGBUILD b/extra/python-pendulum/PKGBUILD
index 3c5c178c..91b2edb8 100644
--- a/extra/python-pendulum/PKGBUILD
+++ b/extra/python-pendulum/PKGBUILD
@@ -3,8 +3,10 @@
_name=pendulum
pkgname=python-pendulum
-#pkgver=2.1.2
+pkgver_real=2.1.2
#pkgrel=$((8+$pkgrel))
+pkgver=3.0.0
+pkgrel=2
pkgdesc="Python datetimes made easy"
arch=(x86_64)
url="https://pendulum.eustace.io/"
@@ -27,24 +29,24 @@ checkdepends=(
python-pytest
python-pytz
)
-source=($pkgname-$pkgver.tar.gz::https://github.com/sdispater/$_name/archive/$pkgver.tar.gz)
+source=($pkgname-$pkgver_real.tar.gz::https://github.com/sdispater/$_name/archive/$pkgver_real.tar.gz)
sha512sums=('c367320ade0d10b7eb9c880286176161b925d7df052f7de85ddd169594bbe778776ea74df451f00186df98be3e32b7399c68ca4b40123e2c456206410e3a1ab2')
b2sums=('c95cd131fc95a0d19ef11f180cc42126cb8a6ea3aaf4b3bbedbc5ce4c1b37a6624f2a1be92f1a6fd6b1f14f5d20fa5f32e8230f896ab7a216f02f00e85b98738')
build() {
- cd $_name-$pkgver
+ cd $_name-$pkgver_real
# NOTE: calling pyproject-build as we otherwise call the project's build.py script:
# https://github.com/sdispater/pendulum/issues/665
pyproject-build --wheel --no-isolation
}
check() {
- cd $_name-$pkgver
+ cd $_name-$pkgver_real
pytest -vv
}
package() {
- cd $_name-$pkgver
+ cd $_name-$pkgver_real
python -m installer --destdir="$pkgdir" dist/*.whl
install -vDm 644 {CHANGELOG.md,README.rst} -t "$pkgdir/usr/share/doc/$pkgname/"
install -vDm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"